Error: .cgi file not found when saving file server settings
Q
After pressing "submit" I'm getting the following error:
File Server tests: api.cgi (or fs.cgi): ERROR ( Not Found The requested URL /cgi-bin/api.cgi was not found on this server. Apache/2.2.15 (CentOS) Server at somedomain.com Port 80 ) But I still can access api.cgi (or fs.cgi) in my browser. What's the problem and how could I fix that?
A
In the case of missing fs.cgi: your file server is not able to properly resolve your main server's DNS name In the case of missing api.cgi: your main server is not able to properly resolve your file server's DNS name Q: I logged into corresponding server with root SSH and checked by running 'ping <domain_name>'. To my surprise, I have found that corresponding domain name is getting resolved to a completely different IP which I don't know at all! But on my home machine everything resolves correctly. How could I fix that? A: You can pin a specific domain name to a specific IP by adding a corresponding record into your server's /etc/hosts file. If you're not sure about editing /etc/hosts file, please report this case to your system administrator (if you have any) or hoster (if you don't have any or if you're a system administrator of this server).
|
Self-hosted scripts for file, video and image hosting. Building them since 2006.