XFileSharing Pro - Random DNS Issue

Posts: 135
Joined: May 05, 2011 4:47 pm

Random DNS Issue

#1 Postby RockDiz » Aug 14, 2012 10:49 pm


I know this is a DNS Issue:

Code: Select all

OK::temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR Can't connect to domain.com:80 (Bad hostname)

LWP::Protocol::http::Socket: Bad hostname 'domain.com' at /usr/local/share/perl5/LWP/Protocol/http.pm line 51.

I only see this on the server page when trying to run cron.pl and putting the file into READONLY mode. The problem is that both my file and main server are online and I havent' changed any settings at all. All files hosted on the file server is still downloadable but I'm unable to upload anything to it through xfilesharing script. any suggestions? Thanks!

Posts: 129
Joined: Apr 30, 2009 10:31 am

#2 Postby bhanuprasad1981 » Aug 15, 2012 7:46 am

add your main site ip to hosts file on file server

Posts: 135
Joined: May 05, 2011 4:47 pm

#3 Postby RockDiz » Aug 16, 2012 5:58 pm

bhanuprasad1981 wrote:add your main site ip to hosts file on file server

thanks! I actually did the opposite.
I've added the File Server's IP to the Main Server's hosts file and it did work but there was one issue. On the server's page of xfilesharing script, no IP showed for the file server although there were no errors after running cron.pl

I just now added the Main Server's IP to the File Server's host file so I hope that helps.

Currently some of my users are getting errors like this:

403 Forbidden
Access to this resource on the server is denied!

Site Admin
Posts: 1834
Joined: Mar 22, 2006 12:32 pm

#4 Postby admin » Aug 16, 2012 6:04 pm

check /etc/hosts on both servers.

Return to “XFileSharing Pro”