XFileSharing Pro - 500 Internal Server Error

Message
Author
mdude
Posts: 78
Joined: Apr 19, 2013 11:26 pm

500 Internal Server Error

#1 Postby mdude » Sep 26, 2013 10:56 pm

I have had my xfilesharing pro website for about 6 months now. I don't get much traffic. I get about 50-100 unique visits a day.

I also run a forum which gets about 500-1000 unique visits a day on the same server

Lately on my xfilesharping pro website and forum website i have been getting

500 Internal Server Error.

In the email it says:

fs.cgi: ERROR <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>


It does not happen all the time. Most times my website works fine. This had started happening since yesterday. Before yesterday I've never had this problem and i have not changed anything recently.


I am on a VPS Host Gator Level 3
http://www.hostgator.com/vps-hosting/

1.13GHZ 768 MB 30 GiG Bandwitch 500 GIG

I contacted HostGator and this is what they said

When I refresh the page 4 or 5 times the MySQL load CPU load gets to 100% and the memory usage hangs at about 20% of the total available on the server. There are other services using memory but nothing nearly as high as MySQL when that page is being loaded.


Can someone give me some suggestions?

bizman
Posts: 95
Joined: Mar 24, 2013 1:57 am

#2 Postby bizman » Sep 27, 2013 12:06 am

check which process is comsuming much mb and delete it, on me it was clamav I saved 230~ mb.

Or get some gb RAM.

mdude
Posts: 78
Joined: Apr 19, 2013 11:26 pm

#3 Postby mdude » Sep 27, 2013 3:53 am

where can i check which process is consuming the most resources?

bizman
Posts: 95
Joined: Mar 24, 2013 1:57 am

#4 Postby bizman » Sep 27, 2013 5:37 am

Do you have ssh access?
Which OS are you using?

If you have SSH you can install a cpanel/webmin/kloco etc
and check with cpanel or you check through ssh but you it depends
which OS you use..

mdude
Posts: 78
Joined: Apr 19, 2013 11:26 pm

#5 Postby mdude » Sep 27, 2013 10:50 am

I have ssh access. But i am not good at using it.

I have a Linux server.

To access my server i mostly use Plesk CPanel

Can I use Plesk?

mdude
Posts: 78
Joined: Apr 19, 2013 11:26 pm

#6 Postby mdude » Sep 27, 2013 11:27 pm

Does it have something to do with fs.cgi?

I still have no idea what is causing this. Is it xfilesharing script or my server?


2013:09:26 20-28-56 Error when requesting API.<br><!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
<address>Apache Server at mywebsite.com Port 80</address>
</body></html>


Return to “XFileSharing Pro”