XFileSharing Pro - add a language, and modify the flag?

Message
Author
DexterBlood
Posts: 8
Joined: Aug 15, 2012 11:11 am

add a language, and modify the flag?

#1 Postby DexterBlood » Aug 20, 2012 9:53 am

I added a language, but I get the British flag for the Italian language.
I did the following:


Code: Select all

 # Language list to show on site
 languages_list => ['english','italian','russian','german','french','arabic','turkish','polish','thai','spanish','japan','hungary','indonesia','dutch','hebrew'],


AND:

Code: Select all

 # Match list between browser language code and language file
 # Full list could be found here: http://www.livio.net/main/charset.asp#language
 language_codes => {'en.*'             => 'english',
                    'it.*'               => 'italian',
                    'cs'               => 'czech',
                    'da'               => 'danish',
                    'fr.*'             => 'french',
                    'de.*'             => 'german',
                    'p'                => 'polish',
                    'ru'               => 'russian',
                    'es.*'             => 'spanish',
                     
                   },


I added the Italian language and in the language folder, "italian.lng"

by editing the script that starts with: (italian.lng)

Code: Select all

italian package;

my $ lang =
{

How come I get the British flag in the language selection menu under the heading Italian?[/code]

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm

#2 Postby PowerChaos » Aug 23, 2012 12:37 am

that probaly has to do with the css
check if the css got this code and the img got that code to

Code: Select all

trf{background-image:url(images/flags.png);height:11px;width:16px;background-repeat:no-repeat;overflow:hidden;display:inline-block;margin-right:3px;}
.trf-it{background-position:-552px 0;}

and for the index (main.html]

Code: Select all

<div id="lang">
<ul>
<li class="top"><a href="<TMPL_VAR site_url>/?op=change_lang&lang=<TMPL_VAR language>"><span class="trf trf-<TMPL_VAR language>"></span><TMPL_VAR language2></a></li>
<TMPL_LOOP languages>
<li><a href="<TMPL_VAR site_url>/?op=change_lang&lang=<TMPL_VAR lang>"><span class="trf trf-<TMPL_VAR lang>"></span><TMPL_VAR lang2></a></li>
</TMPL_LOOP>
</ul>
</div>


hopely this can fix your problem

Greetings From PowerChaos


Return to “XFileSharing Pro”