XUpload - Can't copy file....

Message
Author
frozen
Posts: 2
Joined: Feb 23, 2008 11:34 pm

Can't copy file....

#1 Postby frozen » Feb 24, 2008 12:18 am

Hello there!

I'm using version 2.6 free on a linux server.
I have checked all permissions and pathvalues in the config file very very often.. I even hacked some more debugoutput in the upload.cgi.
I also tried different paths and disabled mod_perl since there seem to exist some problems with mod_perl and perls CGI.

After many hours the problem is still the same..

After selecting and sending the file, upload.cgi starts. It selects the correct tempdir. It creates it's subfolder and writes the flength-file into it. It creates the new CGI. But when it comes to SaveFile2 it breaks. Can't copy file.. Looking at the temp directory i can't see any CGITemp-files. It seems the CGI.pm can't create it's tempfile but it doesn't say this.
The path for tempfiles belongs to the same user and group as the apache (www-data) and is chmod 777. The same applies to the targetdir.

The host I am running is a debian server, in a vmware. The used browser doesn't make a difference, I usually tried with Firefox on localhost or once using firefox with windows.

Unfortunately I can't offer FTP access since there is no ftp-server running and the server is not reachable via internet. It's for testing only..

Any ideas?

Thanks in advance,

frozen

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#2 Postby PilgrimX182 » Feb 25, 2008 7:14 am

Looks you server don't wanna write temp files to your own folder :)

Sometimes this helps: download archive http://www.sibsoft.net/tools/CGI.zip
and upload contents to cgi-bin, so there will be CGI.pm and CGI folder in cgi-bin.
Try now.

Note: Pro3 use enhanced engine so it don't need temp files in our own folder.

frozen
Posts: 2
Joined: Feb 23, 2008 11:34 pm

#3 Postby frozen » Feb 25, 2008 6:08 pm

Hello PilgrimX182,

thank you very much for your reply!

Yeah, I also think, the server didn't want to write temp files to his own directory.

I did not download that archive the way you suggested since this would need more care when updating the machine. Instead I reinstalled apache and perl. That solved it. I suppose the first installation somehow went wrong. Your idea pointed me in the right direction. Thanks!

Have a nice day,

frozen


Return to “XUpload”



Who is online

Users browsing this forum: No registered users and 0 guests