XFileSharing Pro - can't upload after moving the site to new server

Message
Author
hany_c_v
Posts: 14
Joined: Mar 18, 2010 1:35 am

can't upload after moving the site to new server

#1 Postby hany_c_v » Mar 21, 2011 7:22 am

Hi ,'

my website: http://48up.net

I moved my site from a server to another server with full backup

and i installed the Perl modules from the SSH as the following :

perl -MCPAN -e shell
install LWP
install DBI
install DBD::mysql
install GD


Now i can't upload any files and when i check the server

File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: OK
upload.cgi: ERROR (problems with link)
htdocs URL accessibility: OK

and the error

Software error:

Can't locate HTML/Form.pm in @INC (@INC contains: . Modules /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at upload.cgi line 13.
BEGIN failed--compilation aborted at upload.cgi line 13.

For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.


Could you please help me fixing this error???!!!

admin
Site Admin
Posts: 1824
Joined: Mar 22, 2006 12:32 pm

#2 Postby admin » Mar 21, 2011 7:45 am

You're missing HTML::Form perl module.

hany_c_v
Posts: 14
Joined: Mar 18, 2010 1:35 am

#3 Postby hany_c_v » Mar 21, 2011 8:14 am

admin wrote:You're missing HTML::Form perl module.


Thank you very much , it's ok now


Return to “XFileSharing Pro”