Downloadlinks not working

Powerfull XFileSharing version

Moderator: admin

Message
Author
fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

Downloadlinks not working

#1 Postby fsadmin » Jan 17, 2011 10:19 am

Hey guys,

On saturday i checked my site and no links where working so i saw on the fileserver that all xfsconfigs are completely clear.. i have no idea why this is happenend because the server is not full..so yeah i added the configs back but the links arent working. You can visit a link but when u click the download button it dont download. Fileserver has nginx running on it.

example link:
http://filesplash.com/htbzdx2a9vus/DJ_K ... d.mp3.html

maybe there is some who can give me some tips etc.

best

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

Re: Downloadlinks not working

#2 Postby ankurs » Jan 17, 2011 12:32 pm

do you have complete download mod ? then your root has been filled with nginx log file

i am not sure how to clean it, something similar had happened to me & my system administrator had to clear it

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#3 Postby fsadmin » Jan 17, 2011 12:34 pm

hey ankurs i dont have complete download mod i am using 1.6

i dont think that this is a nginx problem..but do u know where the file is located?

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#4 Postby fsadmin » Jan 17, 2011 12:38 pm

apache error log

Code: Select all

[Mon Jan 17 12:30:57 2011] [error] [client 213.5.64.179] script not found or unable to stat: /usr/lib/cgi-bin/upload.cgi
[Mon Jan 17 12:30:58 2011] [error] [client 213.5.64.179] script not found or unable to stat: /usr/lib/cgi-bin/upload.cgi
[Mon Jan 17 12:30:58 2011] [error] [client 213.5.64.179] script not found or unable to stat: /usr/lib/cgi-bin/upload.cgi
[Mon Jan 17 12:30:58 2011] [error] [client 213.5.64.179] File does not exist: /var/www/files
[Mon Jan 17 12:31:00 2011] [error] [client 213.5.64.179] script not found or unable to stat: /usr/lib/cgi-bin/upload.cgi



nginx error log


Code: Select all

2010/11/21 17:37:20 [crit] 2419#0: *6046529 pread() "/usr/local/nginx/html/error_wrong_ip.html" failed (22: Invalid argument) while sending response to client, client: 121.14.76.185, server: localhost, request: "GET /d/i3luolni5ypgxktxr3gzu3xqmsnxztgehxazu6xerqkmu5ov3aayp4ez/kesha%20-%20blow.mp3 HTTP/1.0", host: "s1.filesplash.com", referrer: "http://s1.filesplash.com:182/d/i3luolni5ypgxktxr3gzu3xqmsnxztgehxazu6xerqkmu5ov3aayp4ez/kesha%20-%20blow.mp3"
2010/12/03 16:20:56 [crit] 2422#0: *15058840 pread() "/usr/local/nginx/html/error_wrong_ip.html" failed (22: Invalid argument) while sending response to client, client: 121.14.76.185, server: localhost, request: "GET /d/iplxhsnj5ypgxktxrlgzi3nsmtv2q3qal3tdukv3n3lwpq3s23yv55yv/Chase%20&%20Status%20Ft.%20Dizzee%20Rascal%20-%20Heavy.mp3 HTTP/1.0", host: "cherryload.us", referrer: "http://cherryload.us:182/d/iplxhsnj5ypgxktxrlgzi3nsmtv2q3qal3tdukv3n3lwpq3s23yv55yv/Chase%20&%20Status%20Ft.%20Dizzee%20Rascal%20-%20Heavy.mp3"
2010/12/16 13:14:47 [emerg] 3777#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2010/12/16 13:14:47 [emerg] 3777#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2010/12/16 13:14:47 [emerg] 3777#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2010/12/16 13:14:47 [emerg] 3777#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2010/12/16 13:14:47 [emerg] 3777#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2010/12/16 13:14:47 [emerg] 3777#0: still could not bind()
2011/01/05 17:12:10 [crit] 3769#0: *12637614 pread() "/usr/local/nginx/html/error_wrong_ip.html" failed (22: Invalid argument) while sending response to client, client: 121.14.76.185, server: localhost, request: "GET /d/jdl3kpvi5ypgxktxr7g4q5fbopcw3pc7evmetucwwukqwaqd673y23c6/Travis%20Garland%20(of%20NLT)%20-%20Sunday%20Morning.mp3 HTTP/1.0", host: "s3.filesplash.com", referrer: "http://s3.filesplash.com:182/d/jdl3kpvi5ypgxktxr7g4q5fbopcw3pc7evmetucwwukqwaqd673y23c6/Travis%20Garland%20(of%20NLT)%20-%20Sunday%20Morning.mp3"
2011/01/16 12:20:01 [emerg] 5458#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:20:01 [emerg] 5458#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:20:01 [emerg] 5458#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:20:01 [emerg] 5458#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:20:01 [emerg] 5458#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:20:01 [emerg] 5458#0: still could not bind()
2011/01/16 12:42:18 [emerg] 5520#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2011/01/16 12:42:18 [emerg] 5520#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2011/01/16 12:42:18 [emerg] 5520#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2011/01/16 12:42:18 [emerg] 5520#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2011/01/16 12:42:18 [emerg] 5520#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2011/01/16 12:42:18 [emerg] 5520#0: still could not bind()
2011/01/16 12:47:02 [emerg] 5542#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:47:02 [emerg] 5542#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:47:02 [emerg] 5542#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:47:02 [emerg] 5542#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:47:02 [emerg] 5542#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:47:02 [emerg] 5542#0: still could not bind()
2011/01/16 12:59:16 [emerg] 5576#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:59:16 [emerg] 5576#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:59:16 [emerg] 5576#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:59:16 [emerg] 5576#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:59:16 [emerg] 5576#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 12:59:16 [emerg] 5576#0: still could not bind()
2011/01/16 13:17:58 [notice] 5644#0: signal process started
2011/01/16 13:19:04 [emerg] 5647#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 13:19:04 [emerg] 5647#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 13:19:04 [emerg] 5647#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 13:19:04 [emerg] 5647#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 13:19:04 [emerg] 5647#0: bind() to 0.0.0.0:182 failed (98: Address already in use)
2011/01/16 13:19:04 [emerg] 5647#0: still could not bind()
2011/01/16 13:20:49 [notice] 5648#0: signal process started
2011/01/16 13:20:49 [alert] 3769#0: open socket #41 left in connection 6
2011/01/16 13:20:49 [alert] 3769#0: open socket #28 left in connection 14
2011/01/16 13:20:49 [alert] 3769#0: open socket #26 left in connection 39
2011/01/16 13:20:49 [alert] 3769#0: open socket #43 left in connection 43
2011/01/16 13:20:49 [alert] 3769#0: open socket #12 left in connection 50
2011/01/16 13:20:49 [alert] 3769#0: open socket #35 left in connection 70
2011/01/16 13:20:49 [alert] 3769#0: aborting
2011/01/16 13:20:49 [alert] 3771#0: open socket #11 left in connection 3
2011/01/16 13:20:49 [alert] 3771#0: open socket #35 left in connection 7
2011/01/16 13:20:49 [alert] 3771#0: open socket #23 left in connection 9
2011/01/16 13:20:49 [alert] 3771#0: open socket #24 left in connection 18
2011/01/16 13:20:49 [alert] 3771#0: open socket #28 left in connection 22
2011/01/16 13:20:49 [alert] 3771#0: open socket #15 left in connection 81
2011/01/16 13:20:49 [alert] 3771#0: aborting

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#5 Postby ankurs » Jan 17, 2011 1:40 pm

try restart httpd

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#6 Postby fsadmin » Jan 17, 2011 1:46 pm

i already did the normal things the weird thing is when i set the main server where just the script is located to fileserver and uploading a file than it shows me file not found

http://filesplash.com/odfp4jiuu5s1

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#7 Postby ankurs » Jan 17, 2011 2:14 pm

download link i get is

http://filesplash.com/plash.com:182/d/i ... 111111.mp3

notice plash.com/plash.com:182/d/ihly6

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#8 Postby fsadmin » Jan 17, 2011 2:15 pm

yeah i already notcied that but i have no idea where to look for that..on the main server there is no nignx running

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#9 Postby ankurs » Jan 17, 2011 2:35 pm

check the file server settings, there might be a typo

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#10 Postby fsadmin » Jan 17, 2011 2:43 pm

already chekced it..and the support is not answering..everytime the same s...
on easy things they reply in minutes..but if ur service is down or not usable the dont answer or it tooks ages lol

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#11 Postby ankurs » Jan 17, 2011 5:32 pm

usually on monday they are very busy, try wait till tomm. as their office hours are now over


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests