XFileSharing Pro - Error 500 Installation Issues

Message
Author
imagepad
Posts: 29
Joined: May 12, 2011 5:13 am

Error 500 Installation Issues

#1 Postby imagepad » Feb 05, 2012 5:27 pm

All required modules are installed. I've tried messing with the htaccess a dozen different times and no luck.

Code: Select all

uid: (504/imgpad) gid: (505/imgpad) cmd: install.cgi


Is the only line I'm getting in the error log. I've made sure perl and mod_rewrite is installed but it still is just giving me 500 errors.

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm

#2 Postby PowerChaos » Feb 05, 2012 10:05 pm

500 errors are mostly because of wrong permision settings

are you sure your scripts got 755 as permision or are they on 644 ??

Greetings From PowerChaos

imagepad
Posts: 29
Joined: May 12, 2011 5:13 am

#3 Postby imagepad » Feb 06, 2012 3:43 am

install.cgi is 755 and it's the only that says it needs to be changed.

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm

#4 Postby PowerChaos » Feb 06, 2012 4:40 am

in the file itself
does it contains this line at top

Code: Select all

#!/bin/sh


else i would suggest to take a look at the following page

http://www.doc.ic.ac.uk/csg-old/cgi/

it explains how to fix it if you are running with suEXEC

Greetings From PowerChaos

imagepad
Posts: 29
Joined: May 12, 2011 5:13 am

#5 Postby imagepad » Feb 06, 2012 5:58 am

Code: Select all

Can't locate CGI/Carp.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at ./install.cgi line 3.
BEGIN failed--compilation aborted at ./install.cgi line 3.


That's the error I'm getting if I attempt to run it at command line.

oldmanman
Posts: 20
Joined: Jun 01, 2012 9:00 am

#6 Postby oldmanman » Jun 01, 2012 9:03 am

imagepad wrote:

Code: Select all

Can't locate CGI/Carp.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at ./install.cgi line 3.
BEGIN failed--compilation aborted at ./install.cgi line 3.


That's the error I'm getting if I attempt to run it at command line.


I am getting this error too. Any kind souls to help us solve this issue? I'm running install.cgi on SSH and this is the error message that keeps appearing.

chrda
Posts: 296
Joined: Sep 14, 2009 7:16 pm

#7 Postby chrda » Jun 01, 2012 9:09 am

You just need to install the perl modules.

Did you follow the yum install perlmodules part?

What distro do you use?

oldmanman
Posts: 20
Joined: Jun 01, 2012 9:00 am

#8 Postby oldmanman » Jun 01, 2012 9:23 am

chrda wrote:You just need to install the perl modules.

Did you follow the yum install perlmodules part?

What distro do you use?


If you don't have any Perl modules, you can install them through SSH console manually:
perl -MCPAN -e shell
install LWP
install DBI
install DBD::mysql
install GD

I was following this steps to install the Perl modules but the same error message is showing up.

Not too sure what you meant by distro (sry major noob here), but i am using Plesk on a Linux VPS server (perl is supported).

stdio
Posts: 65
Joined: Mar 27, 2012 4:05 pm

#9 Postby stdio » Jun 01, 2012 12:38 pm

Type this in your shell:

cpan

then type install CGI::Carp

oldmanman
Posts: 20
Joined: Jun 01, 2012 9:00 am

#10 Postby oldmanman » Jun 01, 2012 3:13 pm

Solved! thanks guys


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests