XFileSharing Pro - Error Install Perl Module LWP

Message
Author
mrladeia
Posts: 5
Joined: Feb 11, 2012 12:40 pm

Error Install Perl Module LWP

#1 Postby mrladeia » Jul 03, 2012 1:47 pm

Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.9402)
Enter 'h' for help.

CPAN: Storable loaded ok (v2.20)
Going to read '/root/.cpan/Metadata'
Database was generated on Tue, 03 Jul 2012 11:11:50 GMT
Running install for module 'LWP'
CPAN: Data::Dumper loaded ok (v2.124)
'YAML' not installed, falling back to Data::Dumper and Storable to read prefs '/root/.cpan/prefs'
Running make for G/GA/GAAS/libwww-perl-6.04.tar.gz
CPAN: Digest::SHA loaded ok (v5.47)
CPAN: Compress::Zlib loaded ok (v2.02)
Checksum for /root/.cpan/sources/authors/id/G/GA/GAAS/libwww-perl-6.04.tar.gz ok
Scanning cache /root/.cpan/build for sizes
............................................................................DONE
libwww-perl-6.04/
libwww-perl-6.04/AUTHORS
libwww-perl-6.04/bin/
libwww-perl-6.04/Changes
libwww-perl-6.04/lib/
libwww-perl-6.04/lwpcook.pod
libwww-perl-6.04/lwptut.pod
libwww-perl-6.04/Makefile.PL
libwww-perl-6.04/MANIFEST
libwww-perl-6.04/META.yml
libwww-perl-6.04/README
libwww-perl-6.04/README.SSL
libwww-perl-6.04/t/
libwww-perl-6.04/talk-to-ourself
libwww-perl-6.04/t/base/
libwww-perl-6.04/t/live/
libwww-perl-6.04/t/local/
libwww-perl-6.04/t/net/
libwww-perl-6.04/t/README
libwww-perl-6.04/t/robot/
libwww-perl-6.04/t/TEST
libwww-perl-6.04/t/robot/ua-get.t
libwww-perl-6.04/t/robot/ua.t
libwww-perl-6.04/t/net/cgi-bin/
libwww-perl-6.04/t/net/config.pl.dist
libwww-perl-6.04/t/net/http-get.t
libwww-perl-6.04/t/net/http-post.t
libwww-perl-6.04/t/net/http-timeout.t
libwww-perl-6.04/t/net/mirror.t
libwww-perl-6.04/t/net/moved.t
libwww-perl-6.04/t/net/proxy.t
libwww-perl-6.04/t/net/cgi-bin/moved
libwww-perl-6.04/t/net/cgi-bin/nph-slowdata
libwww-perl-6.04/t/net/cgi-bin/slowread
libwww-perl-6.04/t/net/cgi-bin/test
libwww-perl-6.04/t/net/cgi-bin/timeout
libwww-perl-6.04/t/local/autoload-get.t
libwww-perl-6.04/t/local/autoload.t
libwww-perl-6.04/t/local/get.t
libwww-perl-6.04/t/local/http.t
libwww-perl-6.04/t/local/protosub.t
libwww-perl-6.04/t/live/apache-http10.t
libwww-perl-6.04/t/live/jigsaw/
libwww-perl-6.04/t/live/online.t
libwww-perl-6.04/t/live/jigsaw/auth-b.t
libwww-perl-6.04/t/live/jigsaw/auth-d.t
libwww-perl-6.04/t/live/jigsaw/chunk.t
libwww-perl-6.04/t/live/jigsaw/md5-get.t
libwww-perl-6.04/t/live/jigsaw/md5.t
libwww-perl-6.04/t/live/jigsaw/neg-get.t
libwww-perl-6.04/t/live/jigsaw/neg.t
libwww-perl-6.04/t/live/jigsaw/te.t
libwww-perl-6.04/t/base/protocols.t
libwww-perl-6.04/t/base/ua.t
libwww-perl-6.04/lib/LWP/
libwww-perl-6.04/lib/LWP.pm
libwww-perl-6.04/lib/LWP/Authen/
libwww-perl-6.04/lib/LWP/ConnCache.pm
libwww-perl-6.04/lib/LWP/Debug.pm
libwww-perl-6.04/lib/LWP/DebugFile.pm
libwww-perl-6.04/lib/LWP/MemberMixin.pm
libwww-perl-6.04/lib/LWP/Protocol/
libwww-perl-6.04/lib/LWP/Protocol.pm
libwww-perl-6.04/lib/LWP/RobotUA.pm
libwww-perl-6.04/lib/LWP/Simple.pm
libwww-perl-6.04/lib/LWP/UserAgent.pm
libwww-perl-6.04/lib/LWP/Protocol/cpan.pm
libwww-perl-6.04/lib/LWP/Protocol/data.pm
libwww-perl-6.04/lib/LWP/Protocol/file.pm
libwww-perl-6.04/lib/LWP/Protocol/ftp.pm
libwww-perl-6.04/lib/LWP/Protocol/GHTTP.pm
libwww-perl-6.04/lib/LWP/Protocol/gopher.pm
libwww-perl-6.04/lib/LWP/Protocol/http.pm
libwww-perl-6.04/lib/LWP/Protocol/loopback.pm
libwww-perl-6.04/lib/LWP/Protocol/mailto.pm
libwww-perl-6.04/lib/LWP/Protocol/nntp.pm
libwww-perl-6.04/lib/LWP/Protocol/nogo.pm
libwww-perl-6.04/lib/LWP/Authen/Basic.pm
libwww-perl-6.04/lib/LWP/Authen/Digest.pm
libwww-perl-6.04/lib/LWP/Authen/Ntlm.pm
libwww-perl-6.04/bin/lwp-download
libwww-perl-6.04/bin/lwp-dump
libwww-perl-6.04/bin/lwp-mirror
libwww-perl-6.04/bin/lwp-request
CPAN: File::Temp loaded ok (v0.22)

CPAN.pm: Going to build G/GA/GAAS/libwww-perl-6.04.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for LWP
Could not read '/root/.cpan/build/libwww-perl-6.04-4bZ1E4/META.yml'. Falling back to other methods to determine prerequisites
---- Unsatisfied dependencies detected during ----
---- GAAS/libwww-perl-6.04.tar.gz ----
LWP::MediaTypes [requires]
Encode::Locale [requires]
HTTP::Status [requires]
HTTP::Negotiate [requires]
File::Listing [requires]
HTTP::Daemon [requires]
Net::HTTP [requires]
HTTP::Cookies [requires]
HTTP::Date [requires]
HTTP::Request::Common [requires]
HTTP::Response [requires]
WWW::RobotRules [requires]
HTTP::Request [requires]

Shall I follow them and prepend them to the queue
of modules we are processing right now? [yes]



Please help me?

Guneyd
Posts: 67
Joined: Mar 11, 2011 4:30 pm

#2 Postby Guneyd » Jul 03, 2012 2:11 pm


stdio
Posts: 65
Joined: Mar 27, 2012 4:05 pm

#3 Postby stdio » Jul 03, 2012 2:47 pm

In cpan type install YAML and after it's installed type install LWP

mrladeia
Posts: 5
Joined: Feb 11, 2012 12:40 pm

#4 Postby mrladeia » Jul 03, 2012 4:16 pm

Guneyd wrote:Try installing it using CPAN Minus http://library.linode.com/linux-tools/utilities/cpanm



==> Found dependencies: HTTP::Date
! Can't configure the distribution. You probably need to have 'make'. See /root/.cpanm/build.log for details.

and others dependencies...


how to install the YAML?

stdio
Posts: 65
Joined: Mar 27, 2012 4:05 pm

#5 Postby stdio » Jul 04, 2012 11:31 am

do you have make installed?
as root type yum install gcc make
and then install the modules from cpan as usual.

mrladeia
Posts: 5
Joined: Feb 11, 2012 12:40 pm

#6 Postby mrladeia » Jul 04, 2012 2:27 pm

stdio wrote:do you have make installed?
as root type yum install gcc make
and then install the modules from cpan as usual.


Other result:

Code: Select all

Test Summary Report
-------------------
local/http.t        (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
Files=9, Tests=66, 13 wallclock secs ( 0.08 usr  0.04 sys +  1.49 cusr  0.21 csys =  1.82 CPU)
Result: FAIL
Failed 1/9 test programs. 0/66 subtests failed.
make: *** [test] Error 255
  GAAS/libwww-perl-6.04.tar.gz
  make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports GAAS/libwww-perl-6.04.tar.gz
Warning (usually harmless): 'YAML' not installed, will not store persistent state
Running make install
  make test had returned bad status, won't install without force
Failed during this command:
 GAAS/HTTP-Message-6.03.tar.gz                : make_test NO
 GAAS/File-Listing-6.04.tar.gz                : make_test NO
 GAAS/HTTP-Daemon-6.01.tar.gz                 : make_test NO
 GAAS/libwww-perl-6.04.tar.gz                 : make_test NO

mrladeia
Posts: 5
Joined: Feb 11, 2012 12:40 pm

#7 Postby mrladeia » Jul 05, 2012 11:11 pm

Code: Select all

Can't exec "mysql_config": No such file or directory at Makefile.PL line 83.

Cannot find the file 'mysql_config'! Your execution PATH doesn't seem
not contain the path to mysql_config. Resorting to guessed values!
Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located
Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located
Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located


PLEASE NOTE:

For 'make test' to run properly, you must ensure that the
database user 'root' can connect to your MySQL server
and has the proper privileges that these tests require such
as 'drop table', 'create table', 'drop procedure', 'create procedure'
as well as others.

mysql> grant all privileges on test.* to 'root'@'localhost' identified by 's3kr1t';

You can also optionally set the user to run 'make test' with:

perl Makefile.PL --testuser=username

Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located
Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located
Can't exec "mysql_config": No such file or directory at Makefile.PL line 479.
Can't find mysql_config. Use --mysql_config option to specify where mysql_config is located
Failed to determine directory of mysql.h. Use

  perl Makefile.PL --cflags=-I<dir>

to set this directory. For details see the INSTALL.html file,
section "C Compiler flags" or type

  perl Makefile.PL --help




This server not MYSQL-server is multi server.

Its install without installing the server?


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests