XFileSharing Pro - Error on install_fs.cgi

Message
Author
mjdj1999
Posts: 31
Joined: Jul 14, 2014 4:14 am

Error on install_fs.cgi

#1 Postby mjdj1999 » Aug 08, 2014 11:27 pm

I am getting an error trying to install a fileserver. I am following install.txt in order and keep getting the same issue.

INSTALL.txt:
STEP 2:

Code: Select all

2. CPAN way
perl -MCPAN -e shell
install LWP
install DBI
install DBD::mysql
install GD



This was my results:

Code: Select all

cpan> install LWP
CPAN: Storable loaded ok (v2.20)
Reading '/home/.cpan/Metadata'
  Database was generated on Wed, 06 Aug 2014 02:17:02 GMT
CPAN: LWP::UserAgent loaded ok (v6.06)
CPAN: Time::HiRes loaded ok (v1.9721)
Fetching with LWP:
http://cpan.belfry.net//authors/01mailrc.txt.gz
CPAN: YAML loaded ok (v0.98)
Reading '/home/.cpan/sources/authors/01mailrc.txt.gz'
CPAN: Compress::Zlib loaded ok (v2.064)
............................................................................DONE
Fetching with LWP:
http://cpan.belfry.net//modules/02packages.details.txt.gz
Reading '/home/.cpan/sources/modules/02packages.details.txt.gz'
  Database was generated on Fri, 08 Aug 2014 02:17:02 GMT
............................................................................DONE
Fetching with LWP:
http://cpan.belfry.net//modules/03modlist.data.gz
Reading '/home/.cpan/sources/modules/03modlist.data.gz'
DONE
Writing /home/.cpan/Metadata
CPAN: Module::CoreList loaded ok (v2.18)
LWP is up to date (6.08).

cpan> install DBI
DBI is up to date (1.631).

cpan> install DBD::mysql
DBD::mysql is up to date (4.028).

cpan> install GD
GD is up to date (2.53).


The above step may not have had to be done but I have tried everything else (including a different host) and cannot run install_fs.cgi.

Here is what I get when I go to install_fs.cgi in my browser:

Code: Select all

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.27 (Unix) mod_ssl/2.2.27 OpenSSL/1.0.1e-fips mod_bwlimited/1.4 Server at 96.47.239.152 Port 80


api.cgi CHMOD 0755
install_fs.cgi CHMOD 0755
dl.cgi CHMOD 0755
upload.cgi CHMOD 0755


What did I miss?

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#2 Postby ankurs » Aug 09, 2014 6:22 pm

Check error logs

mjdj1999
Posts: 31
Joined: Jul 14, 2014 4:14 am

#3 Postby mjdj1999 » Aug 11, 2014 7:38 pm

suexec_log:

[2014-08-11 15:26:21]: uid: (502/mysite) gid: (513/mysite) cmd: install_fs.cgi
[2014-08-11 15:26:21]: error: target uid/gid (502/513) mismatch with directory (502/513) or program (0/0) or trusted user (0/10)

error_log:
[Mon Aug 11 15:23:20 2014] [error] [client 151.213.187.67] suexec policy violation: see suexec log for more details
[Mon Aug 11 15:23:20 2014] [error] [client 151.213.187.67] Premature end of script headers: install_fs.cgi
[Mon Aug 11 15:23:20 2014] [error] [client 151.213.187.67] File does not exist: /home/mysite/public_html/500.shtml

Does this help?
Thank you


Return to “XFileSharing Pro”