error while using optional email settings

Powerfull XFileSharing version

Moderator: admin

Message
Author
mtalaat
Posts: 11
Joined: Apr 28, 2009 9:07 pm

error while using optional email settings

#1 Postby mtalaat » May 03, 2009 11:58 pm

I configured my xfilesharing server


##### Email settings #####

# SMTP settings (optional)
smtp_server => 'smtp.mydomain.com',
smtp_user => '[email protected]',
smtp_pass => '123456',


while trying to test send mail from contact page I received this error

Software error:

SMTP auth() command failed: No such file or directory
Need MIME::Base64 and Authen::SASL todo auth


please advice

filethis.info
Posts: 11
Joined: Apr 30, 2009 10:54 pm
Contact:

#2 Postby filethis.info » May 04, 2009 12:06 am

# Ok, first, make sure compiler is installed...
apt-get install gcc make build-essential

# Second, open perl cpan shell to install module
perl -MCPAN -e shell

# Third, check cpan up to date... then reload cpan
install CPAN
reload cpan

# Fourth, the perl shell should not exit, and after update you be in cpan shell still... if not, open shell again
perl -MCPAN -e shell

# Fifth, install MIME::Base64 (probably already installed)
install MIME::Base64

# Sixth, install Authen::SASL (this is probably the missing one)
install Authen::SASL

# Seventh, exit
exit



####### And all should be working now :)

mtalaat
Posts: 11
Joined: Apr 28, 2009 9:07 pm

#3 Postby mtalaat » May 15, 2009 10:25 pm

it seems impossible to setup xfilesharing by the customer.
we purchased this product 2 weeks ago and still receive error messages.

customer receive this error message while create new account.


Software error:

SMTP auth() command failed:
Authentication failed


I do not want you to login to my server and fix it, I want you give me instructions to solve it to avoid it in the future in case we move our server to a bigger one.

I can not call you every time we want to fix a problem or reinstall the server.

filethis.info
Posts: 11
Joined: Apr 30, 2009 10:54 pm
Contact:

#4 Postby filethis.info » May 15, 2009 11:24 pm

Software error:

SMTP auth() command failed:
Authentication failed


This mean your authentication to email server is wrong. Make sure this setting is correct..

Code: Select all

# SMTP settings (optional)
smtp_server => 'smtp.mydomain.com',
smtp_user => '[email protected]',
smtp_pass => '123456',


If you still not work, you can send me your SMTP details and I can test the connection - but I warn you this mean I could send email from your server, but I won't - I will delete this information as soon as I confirm it. It is your choice :)

mtalaat
Posts: 11
Joined: Apr 28, 2009 9:07 pm

#5 Postby mtalaat » May 16, 2009 8:00 am

thank you, your tip solved the problem.

hoop2012
Posts: 2
Joined: Sep 12, 2012 2:45 pm

Re: error while using optional email settings

#6 Postby hoop2012 » Sep 12, 2012 2:50 pm

same problem !

the solotion - on the fileserver or on the mailserver

# Ok, first, make sure compiler is installed...
apt-get install gcc make build-essential

# Second, open perl cpan shell to install module
perl -MCPAN -e shell

# Third, check cpan up to date... then reload cpan
install CPAN
reload cpan

# Fourth, the perl shell should not exit, and after update you be in cpan shell still... if not, open shell again
perl -MCPAN -e shell

# Fifth, install MIME::Base64 (probably already installed)
install MIME::Base64

# Sixth, install Authen::SASL (this is probably the missing one)
install Authen::SASL

# Seventh, exit
exit


mtalaat wrote:I configured my xfilesharing server


##### Email settings #####

# SMTP settings (optional)
smtp_server => 'smtp.mydomain.com',
smtp_user => '[email protected]',
smtp_pass => '123456',


while trying to test send mail from contact page I received this error

Software error:

SMTP auth() command failed: No such file or directory
Need MIME::Base64 and Authen::SASL todo auth


please advice


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests