Error2 at /cgi-bin/upload.cgi line 325

XUpload related questions

Moderator: admin

Message
Author
babela
Posts: 2
Joined: Apr 20, 2007 1:46 am
Contact:

Error2 at /cgi-bin/upload.cgi line 325

#1 Postby babela » Apr 20, 2007 1:55 am

Hi,

Thank you for a great script

the files upload fine and I can see them on the server, but the page does not redirect. When I unhide the hidden frame it shows:

Error2 at /var/www/test.oberrecht.com/cgi-bin/upload.cgi line 325.

I have tried the suggestions in the sticky post but that did not fix the problem.

The tmp and final upload folders are chmod 777

uploaded files lifetime is set to 0

I am using the pro 2.4 version of the script on ubuntu LTS server.

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Apr 20, 2007 6:44 am

Pretty rare problem, probably some permissions issue or .
Here goes quick fix: in upload.cgi find

Code: Select all

opendir(DIR, $dir) || die"Error2";


and replace with

Code: Select all

opendir(DIR, $dir) || return;

babela
Posts: 2
Joined: Apr 20, 2007 1:46 am
Contact:

#3 Postby babela » Apr 20, 2007 3:14 pm

thank you, that worked!


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests