XUpload - Files over 100 MB

Message
Author
punisa
Posts: 3
Joined: Apr 27, 2009 6:53 pm

Files over 100 MB

#1 Postby punisa » Apr 27, 2009 7:07 pm

I've read the posted FAQ and found this bit of info:

13. If you get message "Upload Complete" when trying to upload files over 128Mb, but with small files it's ok, change limit in your mod_security configuration file (usually modsec2.conf):
Code:
SecRequestBodyLimit 1342177280



Seems this is exactly what's happening in my situation. Can anyone please explain what this solution actually means?
Sorry for my obvious lack of knowledge : /


When trying to upload a file that is lets's say 300 MB, my pop-up window immediately after a second or so says "upload complete !"
Still I can see by my cursor that transfer is still taking place, I guess file is actually being uploaded, but the xupload window does not recognize it-

Where can I find "mod_security configuration"?
Actually I've looked for it all over my ftp and it isn't there, guess I'm on shared hosting or something like that : P

Can I somehow change these settings by putting something in my .htaccess file?

Currently my .htacces file in my CGI-BIN is as follows:

Code: Select all

<IfModule mod_security.c>
   SecFilterEngine Off
   SecFilterScanPOST Off
   SetEnvIfNoCase Content-Type "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
</IfModule>

<IfModule mod_gzip.c>
   mod_gzip_on No
</IfModule>

<IfModule mod_deflate.c>
   SetEnvIfNoCase Request_URI testenv.cgi no-gzip dont-vary
   SetEnvIfNoCase Request_URI upload_status.cgi no-gzip dont-vary
   SetEnvIfNoCase Request_URI upload.cgi no-gzip dont-vary
</IfModule>


I won't try to be smarter then I am, I have no clue what these lines mean : ))

Thanks for reading, hope someone can help me out[/code]


UPDATE:
sometimes upload just stops and I get this error in my error console:
Permission denied to call method Location.toString

Any ideas?

Return to “XUpload”



Who is online

Users browsing this forum: No registered users and 0 guests