XFileSharing Pro - How To Generate Another fs_key?

Powerfull XFileSharing version

Moderator: admin

Message
Author
shareitall
Posts: 29
Joined: Jul 05, 2010 12:08 am

How To Generate Another fs_key?

#1 Postby shareitall » Apr 06, 2012 5:45 pm

I keep getting one or the other errors:


File Server tests:
api.cgi: OK
ERROR: fs_key is wrong or not empty
upload.cgi: OK
htdocs URL accessibility: OK

when I add the same fs_key that is in the database I get:

File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR <----------------
upload.cgi: OK
htdocs URL accessibility: OK

Please help!

How can I correct this?

applewar
Posts: 67
Joined: Feb 08, 2011 4:21 am

#2 Postby applewar » Apr 06, 2012 9:04 pm

Have you try to add it directly in your XFSConfig.pm file ?

shareitall
Posts: 29
Joined: Jul 05, 2010 12:08 am

#3 Postby shareitall » Apr 06, 2012 9:08 pm

applewar wrote:Have you try to add it directly in your XFSConfig.pm file ?


Yes.

when I add the same fs_key that is in the database I get:

File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR <----------------
upload.cgi: OK
htdocs URL accessibility: OK

I have been working on this almost all day.

I cannot seem to figure out why I am getting the fs.cgi: ERROR .

When you try to upload a file it goes through the whole process and then nothing. No links and no file uploaded.

stdio
Posts: 65
Joined: Mar 27, 2012 4:05 pm
Location: Europe

#4 Postby stdio » Apr 06, 2012 11:20 pm

Try leaving it empty.

fs_key => '',

shareitall
Posts: 29
Joined: Jul 05, 2010 12:08 am

#5 Postby shareitall » Apr 07, 2012 12:25 pm

stdio wrote:Try leaving it empty.

fs_key => '',


That did not work.

I found a work around solution.

Create a new file server account and went through the "add file server" instructions and then moved all of the files to the new account.

It works perfectly and no issues at the moment.

Thanks for the suggestions just the same! :D


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests