XUpload - initializing upload- too long

XUpload related questions

Moderator: admin

Message
Author
forhair
Posts: 3
Joined: Feb 10, 2009 10:27 pm
Contact:

initializing upload- too long

#1 Postby forhair » Feb 10, 2009 10:36 pm

Dear forum members
I have a problem. when a user upload photos, the pop op window first display "initializing upload" throughout the whole upload process and only in the end the upload bar is showing the upload information and a "upload complete" message. It takes many seconds until the progress bar shows up and this cause many of the users to give up uploading and to stop the filling of the form.
I went through some of the posts here and the solution with the .htaccess file.
My .htaccess has the following code:

Code: Select all

LimitRequestBody 10000000000000

<IfModule mod_security.c>
   SecFilterEngine Off
   SecFilterScanPOST Off
   SetEnvIfNoCase Content-Type "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
</IfModule>

<IfModule mod_gzip.c>
   mod_gzip_on No
</IfModule>

<IfModule mod_deflate.c>
   SetEnvIfNoCase Request_URI testenv.cgi no-gzip dont-vary
   SetEnvIfNoCase Request_URI upload_status.cgi no-gzip dont-vary
   SetEnvIfNoCase Request_URI upload.cgi no-gzip dont-vary
</IfModule>


I also spoke with the host supporters and they confirmed that Keep Alive is enabled in the httpd.conf file.

Please help. thanks.

forhair
Posts: 3
Joined: Feb 10, 2009 10:27 pm
Contact:

#2 Postby forhair » Feb 12, 2009 2:04 am

The progress bar is showing but only briefly in the end after the "initializing upload" message stays couple of seconds...
I am on a shared host. i don't think i can change Apache modules...is there a way to bypass them?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#3 Postby PilgrimX182 » Feb 12, 2009 9:42 am

KeepAlive is not involved. I think you don't have progress bar cause apache is caching your output. This could be due to mod_security or mod_gzip or mod_deflate modules.
.htaccess supposed to disable them but sometimes it's not working.
Try to disable these apache mods and check it out.

forhair
Posts: 3
Joined: Feb 10, 2009 10:27 pm
Contact:

#4 Postby forhair » Feb 12, 2009 3:16 pm

PilgrimX182 wrote:KeepAlive is not involved. I think you don't have progress bar cause apache is caching your output. This could be due to mod_security or mod_gzip or mod_deflate modules.
.htaccess supposed to disable them but sometimes it's not working.
Try to disable these apache mods and check it out.


Actually, i just called my host and they say that all those modules are disabled by default.
Any ideas?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#5 Postby PilgrimX182 » Feb 13, 2009 6:49 am

PM me URL to upload form and FTP details if possible, I will make some tests.


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests