XFileSharing Pro - Installation problem 1.2 version

Powerfull XFileSharing version

Moderator: admin

Message
Author
bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

Installation problem 1.2 version

#1 Postby bosal » Aug 29, 2008 10:14 am

Hello i get this errors:

Code: Select all

Can't locate DBI.pm in @INC (@INC contains: . /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at install.cgi line 5.
BEGIN failed--compilation aborted at install.cgi line 5.


This is here: http://wrzut.net/cgi-bin/install.cgi
The perl version is good: http://wrzut.net/cgi-bin/version.cgi

Plz help quick :)

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Aug 29, 2008 10:24 am

You need DBI and DBD::mysql perl modules to be installed on server.
They can be installed using yum on RH/Fedora or apt-get on Debian/Ubuntu.

bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

#3 Postby bosal » Aug 29, 2008 10:31 am

Ok, installed but now i get:

Code: Select all

install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: Modules /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 4) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: DBM, ExampleP, File, Gofer, Proxy, Sponge.
 at Modules/DataBase.pm line 28


In http://wrzut.net/

What to do how to install it ?

I got some errors when I'm installing the DBD :(

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » Aug 29, 2008 1:08 pm

I'm sorry, I can't help you install required modules on YOUR server.
As I told, try to install it from packages using yum or apt-get.

bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

#5 Postby bosal » Aug 29, 2008 5:31 pm

Ok, now I'm getting this error when I'm try to adding a new file server

Code: Select all

Can't locate LWP/UserAgent.pm in @INC (@INC contains: Modules /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at index.cgi line 922.

bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

#6 Postby bosal » Aug 29, 2008 5:48 pm

Ok LWD lib was missing. :)

bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

#7 Postby bosal » Aug 30, 2008 10:05 am

Ok, i have one more problem,

How to add language in UTF-8 i would like to translate whole land to polish... but i get "????" for polish language alphabetic signs.

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#8 Postby PilgrimX182 » Sep 01, 2008 5:38 am

LWP :)

To add Polish language just create polish.lng file in Languages and use UTF-8 codepage to edit it. Also create polish subfolder in Templates/Pages

bosal
Posts: 22
Joined: Aug 27, 2008 10:34 pm

#9 Postby bosal » Sep 01, 2008 1:05 pm

Yep i know, but i had some errors, it was without one " sign :)


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests