XFileSharing Pro - Missing on admin_servers.html

Message
Author
xfilepro
Posts: 18
Joined: Mar 03, 2012 5:13 pm

Missing on admin_servers.html

#1 Postby xfilepro » May 21, 2012 4:04 am

I custom on file admin_servers.html
I see this file has code

Code: Select all

<Form method="POST">

but i can't see

Code: Select all

</form>


And when i select one server, click "Update servers files / disk used"
Will get error: No servers selected


This is default layout of scripts

Code: Select all

<h3><TMPL_VAR lang_adm_server_mgmt></h3>

<Form method="POST">
<input type="hidden" name="op" value="admin_servers">
<Table class="tbl1" cellspacing=1 cellpadding=3>
<TR class="hdr">
<TD></TD>
<TD>ID</TD>
<TD><TMPL_VAR lang_server_name></TD>
<TD><TMPL_VAR lang_status></TD>
<TD><TMPL_VAR lang_users></TD>
<TD><TMPL_VAR lang_files_hdr></TD>
<TD><TMPL_VAR lang_disk_used></TD>
<TD>IP</TD>
<TD>&nbsp;</TD>
<TD>&nbsp;</TD>
</TR>
<TMPL_LOOP servers>
<TR align=center>
<TD><input type="checkbox" name="srv_id" value="<TMPL_VAR srv_id>"></TD>
<TD><TMPL_VAR srv_id></TD>
<TD align=left><a href="?op=admin_server_add&srv_id=<TMPL_VAR srv_id>"><b><TMPL_VAR srv_name></b></a></TD>
<TD><TMPL_VAR srv_status></TD>
<TD><TMPL_VAR user_types></TD>
<TD><a href="?op=admin_files&srv_id=<TMPL_VAR srv_id>"><TMPL_VAR srv_files></a></TD>
<TD align=left><b><TMPL_VAR srv_disk_percent>%</b> (<TMPL_VAR srv_disk> <TMPL_VAR lang_of> <TMPL_VAR srv_disk_max> Gb)</TD>
<TD><TMPL_VAR srv_ip></TD>
<TD><a href="?op=admin_server_del&srv_id=<TMPL_VAR srv_id>" onClick="return confirm('WARNING: Delete server and all its files?')"><img src="<TMPL_VAR site_url>/images/del.gif" border=0></a></TD>
<TD><a href="?op=admin_server_import&srv_id=<TMPL_VAR srv_id>"><TMPL_VAR lang_import_files></a></TD>
</TR>
</TMPL_LOOP>
<TR><TD colspan=10>
<input type="submit" name="admin_check_db_file" value="<TMPL_VAR lang_run_check_db_file>" class="btn2">
 &nbsp;
<input type="submit" name="admin_check_file_db" value="<TMPL_VAR lang_run_check_file_db>" class="btn2">
 &nbsp;
<input type="submit" name="admin_update_srv_stats" value="<TMPL_VAR lang_update_srv_stats>" class="btn2">
</TD></TR>
</Table>
<br>
<input type="button" value="+ <TMPL_VAR lang_add_new_server> " onClick="document.location='?op=admin_server_add'">
<br><br>
<Table class="tbl1" cellpadding=4 cellspacing=1>
<TR class="hdr"><TD><TMPL_VAR lang_special_functions></TD></TR>
<TR><TD align=center>
<input type="button" value="Run cron.pl" onClick="document.location='<TMPL_VAR site_cgi>/cron.pl'">
</TD></TR>
</Table>



And one more small bug:
In file ipn.cgi
I see on a line:

sub PayPalChecks
{
$transaction = $db->SelectRow("SELECT * FROM Transactions WHERE id=?",$f->{custom}) || writeLog( "Transaction not found: '$f->{custom}'", 'EXIT' );

#$db->Exec("UPDATE Transactions SET txn_id=? WHERE id=?",$f->{txn_id}||'',$transaction->{id});
writeLog("Subscription OK", 'EXIT') if $f->{txn_type} eq 'subscr_signup' && $transaction->{verified}; => Don't Work
writeLog("Subscription cancelled", 'EXIT') if $f->{txn_type} eq 'subscr_cancel';


Log still get "Wrong mc_amount value" whe Subscription Signup

And i change to:
writeLog("Subscription OK", 'EXIT') if $f->{txn_type} eq 'subscr_signup'; # && $transaction->{verified}; => Working now
Last edited by xfilepro on May 21, 2012 3:53 pm, edited 2 times in total.

subeno
Posts: 38
Joined: Mar 06, 2012 5:54 am

Hi

#2 Postby subeno » May 21, 2012 1:37 pm

I upgrade t oV 2.0 too and get also when I click "Update servers files / disk used"
Will get error: No servers selected


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests