XFileSharing Pro - Need help : Error after migration

Powerfull XFileSharing version

Moderator: admin

Message
Author
uob
Posts: 9
Joined: Jan 21, 2013 3:25 am

Need help : Error after migration

#1 Postby uob » Jan 27, 2013 1:53 am

Team,

I just migrated from old server to the new one. but after the migration i encounter alots of error. not too sure what is it about. would like to check if someone did encounter this and how to fix?


When i tried to modified the existing added server, when clicking the submit it will prompt the following error:

Code: Select all

File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: ERROR
temp dir rmdir: ERROR
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: ERROR
upload dir rmdir: ERROR
htdocs dir exist: OK
htdocs dir mkdir: ERROR
htdocs dir symlink: ERROR
htdocs dir symlink del: ERROR
htdocs dir rmdir: ERROR
config read: OK
config write: OK
fs.cgi: OK
upload.cgi: OK
htdocs URL accessibility: OK


The file server destination i put as below:
files URL http://domain.com/files
cgi-bin URL: http://domain.com/cgi-bin

I am wondering if this is permission issue or? if yes, which folder or what permission should i granting for this?

Thanks.




[/code]

uob
Posts: 9
Joined: Jan 21, 2013 3:25 am

#2 Postby uob » Jan 27, 2013 1:57 am

Also, When i tried to test on download. it prompt me the below error.


Code: Select all

Software error:

Can't execute select:
Table 'xfs.IP2Files' doesn't exist at Modules/DataBase.pm line 63.


Do you happen to know why?

camafive
Posts: 4
Joined: Aug 13, 2011 2:35 am
Contact:

#3 Postby camafive » May 08, 2013 4:53 pm

Hi, i also have the same error

Can't execute select:
Table 'sobraode_xfile.IP2Files' doesn't exist at Modules/DataBase.pm line 63.

Nobody can help us?

i have full access to my dedicated server and in phpmyadmin that table does not exists there, but if i check in the folder where mysql store all the database files the table is there as IP2Files.frm and other file IP2Files.ibd

Please Admin help us

Stefanzm
Posts: 85
Joined: Apr 08, 2012 3:41 pm

#4 Postby Stefanzm » May 13, 2013 9:58 am

@camafive , if you do not see that table in phpmyadmin , then you should fix that . Take mysqldump from your old server on that table and insert it into your new one .


@uob , your first problem clearly state that the linux can not modify temp / uploads and htdocs dir . Check your chmod on them (temp and uploads has to be 777 , htdocs i think 755 (you should check on htdocs not sure on that 100%) .
About the database problem , its probably the same as camafive .


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests