XUpload - No progress bar/"Can't open flength" error

XUpload related questions

Moderator: admin

Message
Author
Nicholas
Posts: 1
Joined: Sep 05, 2009 9:57 am

No progress bar/"Can't open flength" error

#1 Postby Nicholas » Sep 05, 2009 10:16 am

Hello,
I'm having the same problem several other people are having: it goes directly to "Transfer complete" without showing a progress bar, and without uploading files. It worked fine on a test server I used to demo the system to my client, but once I uploaded it to the client's server it stopped functioning. Here's what I've tried so far:

* Verified the permissions on all XUpload files and folders
* Made sure I'm using absolute paths in XUploadConfig.pm
* Checked the linebreaks
* Used the .htaccess settings recommended in this forum
* Used the test_up.cgi script to upload a 6.8MB file--result: "Will work ;)"
* Went to upload.cgi in a web browser--result: "Can't open flength at upload.cgi line 169."
* Changed the "use lib" lines in both upload.cgi and upload_status.cgi to include the full path to the CGI folder

Any other suggestions, or pointers to what the "Can't open flength" error is trying to tell me?

-- Nicholas

admin
Site Admin
Posts: 1800
Joined: Mar 22, 2006 12:32 pm

Re: No progress bar/"Can't open flength" error

#2 Postby admin » Sep 14, 2009 4:17 am

If you seeing such error - that does mean that script can't open flength file in temp folder. Most likely you have incorrect temp folder path or incorrect permissions on it There's no other reason for such error message.


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests