NO UPLOAD WORKING, POP UP says "Tranfer complete"

XUpload related questions

Moderator: admin

Message
Author
JMD
Posts: 3
Joined: May 18, 2007 5:07 am

NO UPLOAD WORKING, POP UP says "Tranfer complete"

#1 Postby JMD » May 18, 2007 5:15 am

I installed the script on my server, checked everything concerning the setup. When I try to upload a file, The popup says instantly "transfer complete"... The file size is above 3mb, and never shows up in my upload folder. Same thing happens with both versions of the script (Pro and Free).
What Can I do ?

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » May 18, 2007 5:54 am

What OS? Windows or Linux?
Here's quick hack that can help you: in upload_status.cgi find

Code: Select all

for(1..3)


and change 3 to 30. Try now.

.htaccess files are allowed on your server?

JMD
Posts: 3
Joined: May 18, 2007 5:07 am

#3 Postby JMD » May 18, 2007 7:05 am

Thanks for the reply. I made the changes in upload_status.cgi, but unfortunately the same thing happens again, with even little longer time of response. I'm running the script on Linux server. .htaccess files are allowed, an empty one has always been in the htdocs directory. I also tried to create an .htaccess file in my cgi folder with the codes given supposed to fix that problem, but no progress . You can see what happens here : http://www.kwamey.com/upload_form.html

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » May 18, 2007 8:41 am

In the link you sent me....I've made iframe visible and got this error inside upload.cgi: "Can't copy file from temp dir at upload.cgi line 153."
To get details, in upload.cgi replace

Code: Select all

die"Can't copy file from temp dir";


with

Code: Select all

die"Can't copy file from temp dir ($!)";


I think you've setted up wrong paths in Config or haven't chmoded 777 uploads folder.

JMD
Posts: 3
Joined: May 18, 2007 5:07 am

#5 Postby JMD » May 18, 2007 9:35 am

Hummm... Still doing the same. I double checked, all chmods are looking right, now for the paths I'm not sure wich exact way they have to be written. the content below might help u understand:

1 - .htaccess (644) file with this code:

<IfModule mod_security.c>
SetEnvIfNoCase Content-Type \
"^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
</IfModule>

2 - two folders that I created (777), one named 'tempupload' (for temporary uploads), and the other one 'uploads' (for the uploads)

3 - HEre is my XUploadConFig.pm :
(NOTE that 'myserver.com' has been replaced by kwamey.com exactly the way it is without 'www')


package XUploadConfig;

BEGIN
{
use Exporter;
@XUploadConfig::ISA = qw( Exporter );
@XUploadConfig::EXPORT = qw( $c );
}

our $c=
{
# Directory for temporary using files
temp_dir => 'http://myserver.com/cgi-bin/tempupload',

# Directory for uploaded files
target_dir => 'http://myserver.com/cgi-bin/uploads',

# Path to the template using for upload status window
templates_dir => 'http://myserver.com/cgi-bin/Templates',

# Allowed file extensions delimited with '|'
ext_allowed => 'jpg|jpeg|gif|png|rar|zip|mp3|avi|txt|csv',

# URL to send all input values from upload page
url_post => 'http://myserver.com/cgi-bin/post.cgi',

# The link to redirect after complete upload
# This setting can be submitted from HTML form, then it will have priority
redirect_link => 'http://myserver.com/upload_form.html',

# Max length of uploaded filenames(without ext). Longer filenames will be cuted.
max_name_length => 64,

# Type of behavior when uploaded file already exist on disc. Available 3 modes: Rewrite/Rename/Warn
copy_mode => 'Rename',

# Maximum total upload size in Kbytes
max_upload_size => 70000000,

# Time to keep temp upload files on server, sec (24 hours = 86400 seconds)
temp_files_lifetime => 86400,

};

1;

4 - All cgi files are chmoded 755

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#6 Postby PilgrimX182 » May 21, 2007 5:16 am

lol, I've found your problem: you used URLs instead of Paths: temp_dir, target_dir, templates_dir options should contain full path, e.g. '/var/www/cgi-bin/xupload/temp'


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests