XFileSharing Pro - Not file and not worrk !!!

Powerfull XFileSharing version

Moderator: admin

Message
Author
luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

Not file and not worrk !!!

#1 Postby luckid » Feb 09, 2008 4:48 pm

I just installed version Pro followed all the points but I missing 2 files:

*** Main Server Installation ***

1) Copy all files and folders from "MAIN-dist/cgi-bin" into your cgi-bin folder (folder where perl scripts running)
Copy all files and folders from "MAIN-dist/htdocs" into your htdocs folder (folder with HTML files)
NOTE: use binary mode for FTP when uploading files.

2) Set install.cgi permissions to 755. Then open it in your browser (e.g. http://server.com/cgi-bin/install.cgi)
Follow the instructions so all 4 steps will be OK.

3) After complete install delete install.cgi, install.sql files for security reasons.

4) Change relative URLs in .htaccess file in htdocs to your own ones.
If you don't have .htaccess support on your sever you can copy .htaccess source to htdocs options in httpd.conf and restart Apache.

5) Now go to the "Site Settings" page and set up your server configuration.

6) Add cron.pl script to your crontab to run it every hour.
Sample: 0 * * * * cd /var/www/cgi-bin;./cron.pl >/dev/null 2>&1

7) If you want to use PayPal payments for Premium Accounts, edit paypal settings in the very bottom of XFileConfig.pm

8) Directly after install you'll get message "there are no servers available for upload" on index page.
That's correct. Now let's add first FileServer.


*** File Servers Installation ***

1) Copy all files and folders from "FS-dist/cgi-bin" into FileServer cgi-bin folder.
Copy all files and folders from "FS-dist/htdocs" into FileServer htdocs folder.
NOTE: if you're installing FileServer on same server where MAIN server is, DO NOT use same MAIN server htdocs folder, create sub-folder for this.

2) Set permissions:
temp 777
uploads 777
logs.txt 777
.cgi 755
htdocs 777

3) Edit XFSConfig.pm and set up ONLY 3 fields: temp_dir, upload_dir, htdocs_dir.
You can open env.cgi or env.php in browser to figure out real full path to folder.
NOTE: fs_key field should be initially empty

4) Log In to admin account and open "http://server.com/?op=admin_server_add".
Set up all fields there, then Main server will test & update FileServer configuration and if everything allright you'll see new server on "Server Management" page.
If you got error about saving config, make sure fs_key is not empty in XFSConfig.pm or paste it from Server details page.

5) Delete env.cgi, env.php for security reasons.


this 2 file : ( on black ) env.cgi env.php
There are in dir zip and on server

My site is break not work :? And I can not find error...

For the version "normal" is ok but on Pro NOT work

Site : http://www.srilankaw-share.org/

Tnx in advance :roll:

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#2 Postby luckid » Feb 09, 2008 6:13 pm

My server :
* Perl : v5.8.4 built for i386-linux-thread-multi
* MySQL : mysql Ver 14.12 Distrib 5.0.32, for pc-linux-gnu (i386) using readline 5.0
* Apache mod_rewrite module : OK
* .htaccess files enable : OK

The problem? mmmmmm[/b]

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#3 Postby luckid » Feb 10, 2008 12:53 am

I payd for this (120£) your reply o NOT !!!!

please reply on my answer :!:

Luckid

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » Feb 10, 2008 6:23 am

It looks .htaccess is not enabled, or mod_rewrite is not working, cause http://www.srilankaw-share.org should show this page: http://www.srilankaw-share.org/cgi-bin/index.cgi

I think you've copied index.html and .htaccess from FS-dist, this is not what you should do according to INSTALL. Create subfolder in your htdocs for file server. Re-upload .htaccess from MAIN-dist for correct working.

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#5 Postby luckid » Feb 10, 2008 10:36 am

It ok now ( error my for subfolder htdocs )

Now 1 little error:
Image

this dir is setting 777

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#6 Postby luckid » Feb 10, 2008 11:20 am

same error if i change :
htdocs URL
http://www.srilankaw-share.org o http://www.srilankaw-share.org/htdocs

Image

is very strange :shock:

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#7 Postby PilgrimX182 » Feb 10, 2008 5:17 pm

When you open URL specified as "htdocs URL" you should see these 3 letters: "XFS" (if you set special folder for it, not the same as MAIN site use and copied index.html there)

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#8 Postby luckid » Feb 10, 2008 5:41 pm

Is ok but only whit index.html
If add .htaccess on dir htdocs not working...
upload is ok but download error page 500 :?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#9 Postby PilgrimX182 » Feb 11, 2008 12:33 pm

Strange. Download works without .htaccess?
Then try to comment with # line-by-line in .htaccess to figure out what directive gives 500 error.

By the way, it looks you don't have GD module, set captcha mode to text or disable it, cause now not able to Register.

You can give us FTP access to fix it out.

luckid
Posts: 8
Joined: Feb 09, 2008 4:42 pm

#10 Postby luckid » Feb 11, 2008 1:49 pm

Pm on you.... i Hope.... :?


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests