XFileSharing Pro - Please Help me !!!!!!

Powerfull XFileSharing version

Moderator: admin

Message
Author
micromaster
Posts: 19
Joined: Nov 08, 2009 9:55 pm

Please Help me !!!!!!

#1 Postby micromaster » Aug 23, 2012 5:32 pm

My Apache servers are crashing alot.

i have 2 servers which are with the following configuration:

Xen Quad Core 3.10Ghz
8GB DDR3 ECC Ram
2 X 500GB Raid 1
1Gbps Port Speed

After my downloads go up to a range for 1000 downloads the servers start to not respond.

I have direct linking opened and it would stop showing the links and give an error 504 timout nginx, then that apache stops responding.

The 2 servers are doing the samething, why???

I have 1 Main Server and 2 File Servers with specs mentioned above.

Please Help

gLoad
Posts: 33
Joined: Feb 26, 2012 6:12 pm

#2 Postby gLoad » Aug 23, 2012 6:18 pm

With 1000 downloads you mean 1000 different users downloading at the same time ?

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm
Location: belguim
Contact:

#3 Postby PowerChaos » Aug 23, 2012 11:01 pm

just wrong config
or out of ram , or high cpu

it all depends on the config
and in your case , if you got 1000 users online/downloading at the same time then even no network anymore ( 1GB = 1000 downloads @ 1mbps )

those days the average downlaod speed is 30mbit ( aka 3,75 MB per second )

so 1000 users downlaoding at the same time = 1mbps = 0,13 MB/s )

and that will expain why nothing is responding anymoe

as the webserver need to generate teh links , does it get also a timeout when the fileserver can not response ( unnable to generate links )

Greetings From PowerChaos


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests