PopUp Window just showing Transfer Completed

XUpload related questions

Moderator: admin

Message
Author
zorn
Posts: 2
Joined: Oct 27, 2006 1:25 pm

PopUp Window just showing Transfer Completed

#1 Postby zorn » Oct 27, 2006 1:31 pm

Hi all,

i want to use the free version of xupload but i've got a little problem:

the first time i try to upload a file, the popup window just shows me "Transfer completed" and "close window", nothing more. If I try to upload another file the popup shows correctly the statusbar, time, etc.

Does anybody know, how to solve this problem? The problems occurs only the first time you go to the upload-page.

I hope somebody can help...

Sorry for the bad english, i've tried my best ;)

thx to all ;)

zorn ;)

tubbly
Posts: 18
Joined: Sep 06, 2006 10:59 pm

#2 Postby tubbly » Oct 30, 2006 9:32 am

I'm using the Pro version but have also noticed this problem sometimes.

I can't pin it down to any particular browser (though we mainly use Safari on Mac OS X) and in my case it does NOT do it every first time I use the Upload Page, but perhaps every 5 times or so.

I've recently started trying out Firefox with Mac OS X and so far have not had the problem so I'm assuming it's a browser problem.

I usually just refresh the page and select the file to upload again!

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#3 Postby PilgrimX182 » Oct 30, 2006 12:54 pm

Make sure you put right paths in the config. Use .htaccess posted on xupload main page.

zorn
Posts: 2
Joined: Oct 27, 2006 1:25 pm

#4 Postby zorn » Oct 30, 2006 5:37 pm

hi @ all ;)

thanx for the answers :)

i've solved the problem by uncommenting line 34 in upload_status.cgi: sleep 1;

now the upload-page works without any problems :)

thanx to all,

zorn ;)

mrsippy
Posts: 1
Joined: Oct 30, 2006 10:30 pm

Same problem under IIS

#5 Postby mrsippy » Oct 30, 2006 11:04 pm

I have just purchased the pro version and have a similar problem, that is not solved by the above solution.
The web server is IIS.
The whole thing works nicely on my own PC, which is running IIS for my developing. Everything displays correctly, files appear in the temp transfer directory, then are moved to the uploads directory. Progress bar displays correctly.

However it does not work on any other PC. The main page (http://development.tenderlink.com/XUplo ... _form.html) displays fine, with the correct number of upload files etc.. but when I go to upload my files in a pop-up window, it delays for a while - then says transfer complete (because there is no flength file in my transfer directory, in fact it is completely empty - no folders are even created).
However in the background the transfer is obviously still happening, because about 30 seconds later a folder briefly appears in the transfer directory, then it is instantly moved to the upload directory, where I can now see the file. My original upload page then takes me on to the redirect page I have set up.
So in the end I get the file OK, but there is no progress, as there is nothing in the temp folder during the entire upload.
None of this happens when I start the upload on teh PC running IIS.
Any help would be most appreciated.... Thanks

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#6 Postby PilgrimX182 » Oct 31, 2006 6:28 am

mrsippy, the sympthoms are very similar to that when you have cluster on that 'other PC'. Do you? We had this situation once. The problem is that file synchronisation is a bit slow between cluster nodes.

Try these modifications:

in upload_status.cgi find "for(1..3)" and change to "for(1..10)", also find "my $ftime = (lstat($flength_file))[9];" and change to "my $ftime = time;"

If this won't help you can email us FTP/SSH access to your server to debug/fix the script for that server.

ap
Posts: 21
Joined: Jan 08, 2007 10:35 pm

#7 Postby ap » Jan 16, 2007 8:54 pm

Also, I am wondering if the script is struggling if the network or internet slows down, lets say to 49kbps. Does script get confused? If I change the line "if($curr_time-$modif_time>30) # 30 seconds without filesize modification means upload failure" to a very high number under the upload_status.cgi script, will this help the script to reconnect to the sever and make the prgress bar and status window operate correctly. Just some food for thought.

was
Posts: 2
Joined: Jan 21, 2007 12:37 pm

#8 Postby was » Jan 21, 2007 1:05 pm

We use PRO version and everything worked fine until we moved to a new hosting.

Currently if ‘Show upload status’ box is checked, popup window doesn’t show progress bar, but only 'Transfer completed. Close' and the original upload page doesn’t redirect me to the thank you page!
If ‘Show upload status’ box isn’t checked I’m redirected to the thank you page.
Files are uploaded successfully in both cases.

What can be the problem with a progress bar?

I use your .htaccess file and set up CHMODs correctly.

User avatar
PilgrimX182
Posts: 2181
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#9 Postby PilgrimX182 » Jan 22, 2007 6:41 am

Are you sured .htaccess alowed on this new hosting?

Not sured how progress bar affect main upload in your case. Please PM me URL to your upload form to check things out.

dynagraphics
Posts: 4
Joined: Aug 04, 2011 4:45 pm

First upload attempt fails...

#10 Postby dynagraphics » Aug 31, 2011 7:46 pm

I too am having the issue of the first upload attempt failing. If I refresh the page and try again it always works. It only fails on the first attempt. Doesn't matter what browser. I've tried the solutions above but they're not fixing the problem for me. Anyone know how to fix the issue? I've checked and double-checked my file paths and my file permissions. I don't think either of those are to blame. Any help would be appreciated.

Admin: If it would be helpful I'll PM you my FTP info for you to troubleshoot and fix the problem. Using Xupload Pro. Thanks!

printpedia
Posts: 1
Joined: Sep 30, 2011 10:18 am

Showing "Transfer Complete" Directly

#11 Postby printpedia » Sep 30, 2011 11:15 am

Dear All,

My website is using XUpload . The link is www.printpedia.info/upload1.php

When I am trying to upload files it is showing Transfer Complete directly whereas in the background the upload is actually going on.

The problem is that the flength file cannot be created though the temp dir is mentioned properly.

Can any webmaster or Perlmaster help me out. Thanks in advance.

TobiX
Posts: 3
Joined: Aug 19, 2009 8:12 am

Initialize - Transfer complete!

#12 Postby TobiX » Mar 20, 2014 1:19 pm

I think, I do have the same Problem.

First it initializes and after a while - depending on what value is set in upload_status.cgi for(1..3) - the window shows Transfer complete! (no status-window appears). But the transfer is still in progress. When finished, the "thankyou"-page appears.

This is a very bad behaviour, because if the user closes the window (because the transfer for him is completed), the transfer stops and the file is lost.

(XUPLOAD 3.1 on win and osx, different browsers,
.htaccess file on place, file rights correct...)

On a different server it worked fine...


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests