XFileSharing Pro - Problem + Add to my account Not Working.

Powerfull XFileSharing version

Moderator: admin

Message
Author
HOWAREYA
Posts: 7
Joined: Oct 13, 2010 2:12 pm

Problem + Add to my account Not Working.

#1 Postby HOWAREYA » Oct 13, 2010 2:14 pm

Hello on the catalog the + Add to my account function is not working. It just says working... then loads a iframe with the main page displayed. Please can anyone help with this issue?

Thanks

admin
Site Admin
Posts: 1801
Joined: Mar 22, 2006 12:32 pm

#2 Postby admin » Oct 14, 2010 12:53 pm

Strange, but there should be no iframe. Maybe you messed something during design customization?

HOWAREYA
Posts: 7
Joined: Oct 13, 2010 2:12 pm

#3 Postby HOWAREYA » Oct 16, 2010 6:12 pm

FIXED.
Ok i found the problem.
You cant link to the catologue like this mysite.com/catalogue.html otherwise page navigation and add to my account doesn't work. The URL has to be like this /?op=catalogue for it to work.

venture89
Posts: 95
Joined: Aug 30, 2011 12:11 am
Location: Planet Z

#4 Postby venture89 » Oct 16, 2012 4:46 pm

We have the same issue.
Is it a good idea to redirect all hits with www to the same page without www?
like this

Code: Select all

RewriteEngine On
RewriteCond %{HTTP_HOST}  ^www.example.com [nocase]
RewriteRule ^(.*)         http://example.com/$1 [last,redirect=301]

afdah
Posts: 147
Joined: Jan 27, 2012 2:23 pm

#5 Postby afdah » Oct 17, 2012 2:52 pm

in catalogue.html

find the below code

Code: Select all

<TMPL_IF add_to_account><div id="am<TMPL_VAR file_id>"><a href="#" class="url2" onClick="return jah('?op=my_files&add_my_acc=<TMPL_VAR file_code>','am<TMPL_VAR file_id>');">+ <TMPL_VAR lang_add_to_my_account></a></div></TMPL_IF>


replace with

Code: Select all

<TMPL_IF add_to_account><div id="am<TMPL_VAR file_id>"><a href="#" class="url2" onClick="return jah('<TMPL_VAR site_url>/?op=my_files&add_my_acc=<TMPL_VAR file_code>','am<TMPL_VAR file_id>');">+ <TMPL_VAR lang_add_to_my_account></a></div></TMPL_IF>


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests