XUpload - problem uploading to a folder specified in form.

XUpload related questions

Moderator: admin

Message
Author
ibiz
Posts: 6
Joined: Sep 16, 2007 3:14 am

problem uploading to a folder specified in form.

#1 Postby ibiz » Sep 16, 2007 3:35 am

Hi all,

I just got pro and I've added a hidden field for "ext_folder".

I also set allow_ext_folder option inside XUploadConfig to 1.

And, I set the form to upload to a subfolder inside my master target_dir folder specified for the upload mode.

But... I keep getting this error:

"Fatal Error: Can't copy file from temp dir (No such file or directory)"

Both temp directory and upload directory has been CHMOD to 777

Everything works fine when I set "allow_ext_folder" option to 0.

I can't figure out how to correct this. Please help.

Thank you!

Jim

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Sep 18, 2007 9:12 am

Imagine you target_dir='/var/www/uploads'
You specify ext_folder='admins' in form
allow_ext_folder = 1

Not working fine? Maybe you specified full path in form instead of folder name?

To do more debug in upload.cgi find

Code: Select all

xmessage("Fatal Error: Can't copy file from temp dir ($!)");

and replace with

Code: Select all

xmessage("Fatal Error: Can't copy file from temp dir ($!)($temp)($dir/$fname)");

ibiz
Posts: 6
Joined: Sep 16, 2007 3:14 am

Thank you

#3 Postby ibiz » Sep 24, 2007 4:38 pm

Thank you for your help.

Problem solved. Needed to use folder name instead of real path.

Great support!

Thanks a million.


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests