XFileSharing Pro - problem with adding the sever

Powerfull XFileSharing version

Moderator: admin

Message
Author
charbel
Posts: 4
Joined: May 28, 2011 1:51 pm

problem with adding the sever

#1 Postby charbel » Jul 18, 2011 6:49 am

api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR Can't connect to xxxxxx.com:80 (Permission denied) LWP::Protocol::http::Socket: connect: Permission denied at /usr/lib/perl5/site_perl/5.8.8/LWP/Protocol/http.pm line 51.
upload.cgi: OK
htdocs URL accessibility: OK

Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

#2 Postby Belgin Fish » Jul 19, 2011 12:21 am

make sure port 80 is open

banimp3
Posts: 24
Joined: Dec 06, 2009 5:23 pm

#3 Postby banimp3 » Feb 03, 2012 11:46 pm

I have the same problem, anyone know how to fix it?

verzing
Posts: 141
Joined: Mar 02, 2011 7:00 pm

#4 Postby verzing » Feb 04, 2012 12:40 am

- You can't use subdomain of main server domain for file server domain.
I don't know why we get this error , Im got this error when I want move file server to new server different with main server (2 server , 1 for main and 1 for file).


- if you have another domain name , just use another domain name for file server. you can use subdomain of another domain name for file server domain.

work fine.

banimp3
Posts: 24
Joined: Dec 06, 2009 5:23 pm

#5 Postby banimp3 » Feb 04, 2012 2:01 am

verzing, Thank you for the reply, but trying to add the main server I got the same error.

Another point is that I have 2 Licenses of Xfilesharing, and with one of them I don't get this error, I'm using subdomain without error.

Is very strange this issue.

banimp3
Posts: 24
Joined: Dec 06, 2009 5:23 pm

#6 Postby banimp3 » Feb 04, 2012 4:48 am

verzing i found the error and fixed it, are you still requiring the fix?

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm
Location: belguim
Contact:

#7 Postby PowerChaos » Feb 06, 2012 5:02 am

verzing wrote:- You can't use subdomain of main server domain for file server domain.
I don't know why we get this error , Im got this error when I want move file server to new server different with main server (2 server , 1 for main and 1 for file).


- if you have another domain name , just use another domain name for file server. you can use subdomain of another domain name for file server domain.

work fine.


eum
http://boosterking.com is my main domain (server 1)
http://premium.boosterking.com -> server2
http://data.boosterking.com -> torrents

so i guess you messed up a few things as i am already using 2 subdomains of my main domain and they are working perfect

or it is the new version that got a small bug maybe , as i use version 1.8

Greetings From Powerchaos

verzing
Posts: 141
Joined: Mar 02, 2011 7:00 pm

#8 Postby verzing » Feb 06, 2012 5:28 am

banimp3 wrote:verzing i found the error and fixed it, are you still requiring the fix?


yes, can you tell me how to fix it .

banimp3
Posts: 24
Joined: Dec 06, 2009 5:23 pm

#9 Postby banimp3 » Feb 06, 2012 11:43 am

The issue was due to SElinux beign active.

If your server is running CentOS you can disable it by running the command "setup" then go to firewall configuration and disable both "security level" set to disabled and "SElinux" set to disabled.

In my case that works.

verzing
Posts: 141
Joined: Mar 02, 2011 7:00 pm

#10 Postby verzing » Feb 06, 2012 12:21 pm

banimp3 wrote:The issue was due to SElinux beign active.

If your server is running CentOS you can disable it by running the command "setup" then go to firewall configuration and disable both "security level" set to disabled and "SElinux" set to disabled.

In my case that works.


Thanks you , im just disable Selinux but I didn't test add new server yet.

banimp3
Posts: 24
Joined: Dec 06, 2009 5:23 pm

#11 Postby banimp3 » Feb 06, 2012 1:06 pm

You're welcome, it should work now ;)

verzing
Posts: 141
Joined: Mar 02, 2011 7:00 pm

#12 Postby verzing » Feb 09, 2012 6:44 pm

didn't work,
@Charbel
do you resolve this problem yet ?

admin
Site Admin
Posts: 1800
Joined: Mar 22, 2006 12:32 pm

#13 Postby admin » Feb 10, 2012 3:28 am

verzing wrote:didn't work,
@Charbel
do you resolve this problem yet ?


That's really looks like selinux problem.
How did you disabled it?

verzing
Posts: 141
Joined: Mar 02, 2011 7:00 pm

#14 Postby verzing » Feb 10, 2012 7:43 am

admin wrote:
verzing wrote:didn't work,
@Charbel
do you resolve this problem yet ?


That's really looks like selinux problem.
How did you disabled it?


I disabled via ssh
Image


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests