XFileSharing Pro - Problem with automatically convert account to Premium

Powerfull XFileSharing version

Moderator: admin

Message
Author
KristiKristo
Posts: 35
Joined: Jan 04, 2011 11:11 pm

Problem with automatically convert account to Premium

#1 Postby KristiKristo » Mar 13, 2011 3:59 pm

Hello
I have problems with converting the account to Premium. When the user pays the money for Premium account, I receive them on my paypal, but he doesnt get the premium account automatically.

I have putted the notification url to http://www.mysite.com/cgi-bin/ipn.cgi on my PayPal.

I get the following error on my ipn_log:
Sun Mar 13 07:59:58 2011 : Got answer: Can't verify SSL peers without knowning which Certificate Authorities to trust

This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
envirionment variable or by installing the Mozilla::CA module.

To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
envirionment variable to 0. If you do this you can't be sure that you
communicate with the expected peer.

Sun Mar 13 07:59:58 2011 : Error HTTP


Please advise me :)

Regards

glumbo
Posts: 211
Joined: Mar 11, 2011 6:26 am
Location: US

#2 Postby glumbo » Mar 13, 2011 4:32 pm

Looks like you need to install those modules. Just google for info

Does your server fit these requirements?

http://www.sibsoft.net/xfilesharing.html#requirements

KristiKristo
Posts: 35
Joined: Jan 04, 2011 11:11 pm

#3 Postby KristiKristo » Mar 13, 2011 7:05 pm

Yes, the server fit the requirements. Where can I find those modules so I can install them?

gkhn
Posts: 7
Joined: Dec 09, 2008 10:36 am
Contact:

#4 Postby gkhn » Mar 13, 2011 7:47 pm

I have same problem. How can I solve ?

GoldFinger
Posts: 6
Joined: Mar 13, 2011 9:08 pm

#5 Postby GoldFinger » Mar 13, 2011 9:09 pm

I would think support should do that

pcspost
Posts: 14
Joined: Dec 01, 2010 8:05 am

#6 Postby pcspost » Mar 14, 2011 12:03 am

Wow...I too am having this problem now. Everything was working fine until a few days ago when I started getting complaints from people that paid and their account was not upgraded. I assume it has to be a change with Paypal if everyone else is also having this problem.

I plan to contact support now so I hope they reply to this with a fix for the problem. I am really getting some flack from my customers over this.

admin
Site Admin
Posts: 1801
Joined: Mar 22, 2006 12:32 pm

#7 Postby admin » Mar 14, 2011 8:51 am

Looks like LWP was automatically updated on your server to version 6.
Now you need to install Perl module Mozilla::CA.

KristiKristo
Posts: 35
Joined: Jan 04, 2011 11:11 pm

#8 Postby KristiKristo » Mar 14, 2011 10:35 am

Can you please help us providing the page where we can find Mozilla::CA module?

KristiKristo
Posts: 35
Joined: Jan 04, 2011 11:11 pm

#9 Postby KristiKristo » Mar 14, 2011 10:39 am

Solution found. Just search for the module in your server and install it.

Thanks a lot

Regards
Kristi Kristo

gkhn
Posts: 7
Joined: Dec 09, 2008 10:36 am
Contact:

#10 Postby gkhn » Mar 14, 2011 3:50 pm

It's working. Thanks admin

pcspost
Posts: 14
Joined: Dec 01, 2010 8:05 am

#11 Postby pcspost » Mar 14, 2011 11:10 pm

Great, installing the Perl module Mozilla::CA fixed the problem. Thanks for pointing that out.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests