Software error - Cant upload.

Free version of Xfilesharing

Moderator: admin

Message
Author
mahmood13
Posts: 2
Joined: Feb 24, 2009 1:17 pm

Software error - Cant upload.

#1 Postby mahmood13 » Feb 24, 2009 1:18 pm

Hi there,

I have a problem with your script (XFileSharing), I cant't upload files when I try to the progress goes to 100% then it displays "Upload complete. Saving files...
Upload complete. Saving files... ", And when i made the iframe in that page visible I got this messege:

Software error:

Can't exec:s REPLACE INTO Secure (file_id,ip,rand,captcha,time) VALUES (?,INET_ATON(?),?,?,NOW()+INTERVAL ? SECOND)
Column 'ip' cannot be null at TCM/DataBase.pm line 65.

Also this shown when I click contact us link, I have tried what has been suggested in This Thread but it didnt help, but when I tried using proxy to access my website the error didnt show and can upload files normally, So it could be a bug from the software.

Any help to resolve this issue appreciated.

Kind Regards,
Mahmood Majeed

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Feb 25, 2009 2:23 pm

replace this code in Session.pm:

Code: Select all

return $ENV{HTTP_X_FORWARDED_FOR} || $ENV{REMOTE_ADDR};

with

Code: Select all

return $ENV{REMOTE_ADDR};

mahmood13
Posts: 2
Joined: Feb 24, 2009 1:17 pm

#3 Postby mahmood13 » Feb 25, 2009 2:58 pm

fixed it yesterday, anyway thanks.

I tried this solution yesterday you post it in another thread but it didnt help, but then I tried to go to the SQL database and edited the ip field in files table so it can be null and now it worked with the combination of what you suggested and what I have done.

Regards


Return to “XFileSharing Free”

Who is online

Users browsing this forum: No registered users and 0 guests