XFileSharing Pro - some questions...

Message
Author
abboodeh
Posts: 94
Joined: Jan 23, 2009 6:31 pm

some questions...

#1 Postby abboodeh » Mar 04, 2009 12:49 pm

Hi

few questions:

1. A-why sometimes when i'm remote uploading something or directly uploading something from my PC sometimes the uploading completly stops!

B- is it because i'm using a shared hosting? i'm moving to a dedicated server in two weeks will this solve the problem?



2. i have assigned 2 points for each download, why one file got downloaded for more than 150, and many other files were downloaded and the user get only 16 premium points???

3. A-suppose i have set a 30 days of file deletion after the last download, members came and uploaded and uploaded....
after 1 week i changed the option and made the file deletion after 100 days, will this effect the old files wheich were already upladed or it only effects new files ?

B-Same question in case of changing the premium points reward

4. A- why when uploading process starts, when i click in progressive "on" it dosn't change to off, technically, the progress complete and no further data appear, but the word (off) don't appear?
B- why when switching to off, and then decide to go on again, why sometime it doesn't switch? it stays at off the whole time?

PS in question A+B the word <on> is always there

5. Nothing so far, Thanks in advance for Anwering :)

abboodeh
Posts: 94
Joined: Jan 23, 2009 6:31 pm

#2 Postby abboodeh » Mar 10, 2009 11:53 pm

any answers ?
Pilgrim???

abboodeh
Posts: 94
Joined: Jan 23, 2009 6:31 pm

#3 Postby abboodeh » Mar 11, 2009 10:31 am

please some help :(

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#4 Postby PilgrimX182 » Mar 11, 2009 1:20 pm

1. Don't know. Probably it's really shared hosting too overloaded and gives instant error. Try to make 'xupload' iframe visible and check the error inside. Move to dedi ofcourse, shared is not an option for file-sharing for sure.

2. Don't know. Only can tell you how we calculate this: we have IP-to-File table so if there's no match - then we add points. You've assigned 2 points for free users or for reg or for premium?

3. We use this setting when running cron.pl so ALL files will be affected. With rewards: gained points won't be affected. New points rate will be applied only to new downloads.

4. It's a bug, sorry. I guess this works only in Opera. Will be fixed in upcoming version. Or can give you quick fix.

abboodeh
Posts: 94
Joined: Jan 23, 2009 6:31 pm

#5 Postby abboodeh » Mar 11, 2009 11:34 pm

Thanks pilgram, i just moved to a dedicated server yesterday, and the uploading problem is solved now.

I've assigned 4 points to premium and 2 points for registered, in our case the premium user his 1 file got downloaded more than 180 and he got only around 40 points.
Keeping in mind that users were not able to download the full files, their download used to disconnect in the middle
Does this have to do anything with the problem?

And finally,regarding this bug,just tell me how can i remove the whole option?
I mean,i want all uploading to have progress bar and uploader wont have the option to turn it off
And what quick fix are you suggesting?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#6 Postby PilgrimX182 » Mar 11, 2009 11:49 pm

1) Check how points will work out on new server. Probably shared was behind reverse proxy or smth.

2) Just remove from /tmp/status.html line started with

Code: Select all

<div id="onoff">....

abboodeh
Posts: 94
Joined: Jan 23, 2009 6:31 pm

#7 Postby abboodeh » Mar 12, 2009 3:21 am

Excellent!
thanks a lot !

i will give it some days and see, i believe it's because of the shared hosting....let's wait and see...

thank you Pilgrim :)


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests