XFileSharing Pro - Status.html is downloaded at file upload

Powerfull XFileSharing version

Moderator: admin

Message
Author
Anturaju93
Posts: 91
Joined: May 13, 2010 6:46 pm
Location: Romania

Status.html is downloaded at file upload

#1 Postby Anturaju93 » Feb 01, 2012 6:50 am

I have a big problem with one fileserver.
When a file is uploaded status.html is downloaded automatically.
What can i do?
Admin, do i need this perl modules installed on fileserver:
File::Path
LWP::UserAgent
HTTP::Request::Common
File::Copy
Digest::MD5
HCE_MD5 - posibil sa nu fie
CGI::Simple
Fcntl ':flock'
LWP::UserAgent
Digest::MD5
HTML::Form
Encode
CGI::Simple
Exporter
Apache and CGI is configure correctly.

Anturaju93
Posts: 91
Joined: May 13, 2010 6:46 pm
Location: Romania

#2 Postby Anturaju93 » Feb 02, 2012 9:32 am

Admin, please can you help me?
I checked and i have all the perl modules installed.
Still status.html is downloaded at file upload.
:(

admin
Site Admin
Posts: 1800
Joined: Mar 22, 2006 12:32 pm

#3 Postby admin » Feb 02, 2012 10:08 am

There's nothing to do with perl modules. Check your apache config and maybe .htaccess in tmp folder. It shouldnt downloading.

Anturaju93
Posts: 91
Joined: May 13, 2010 6:46 pm
Location: Romania

#4 Postby Anturaju93 » Feb 02, 2012 10:51 pm

status.html is downloaded only on Google Chrome
On Firefox the status-bar is not working and showing some code on upload page,
On Google Chrome when o hit upload, status.html from htdocs/tmp is downloaded automatically, but upload and download works fine.
I have this problems only at one file server.

I must mention that this file server is at my home, using NAT and now DMZ to be accessible from outside the network. I used a fileserver at my home before, with succes, but this one is downloading status.html at upload.

This is my VirtualHost config:

Code: Select all

DocumentRoot /home/atom
ServerName atom.abcdownload.ro
<Directory "/home/atom">
AllowOverride All
allow from all
Options +Indexes
</Directory>
ServerAdmin [email protected]
ScriptAlias /cgi-bin "/home/atom/cgi-bin"

I use my network IP for apache virtualhost, because when i use external IP apache is not looking in /home/atom , is looking in /var/www/html even for virtualhosts.
Admin can you help my? I can pay you for the solution.

If i remove the javascript code from status.html then the file is not downloaded anymore.

Anturaju93
Posts: 91
Joined: May 13, 2010 6:46 pm
Location: Romania

#5 Postby Anturaju93 » Feb 02, 2012 11:16 pm

Using google i have figured out:
This is the corect config for VirtualHost:

Code: Select all

DocumentRoot /home/atom
ServerName atom.abcdownload.ro
<Directory "/home/atom">
AllowOverride All
allow from all
Options Indexes [b]Includes[/b]
[b]AddHandler server-parsed .html[/b]
</Directory>
ServerAdmin [email protected]
ScriptAlias /cgi-bin "/home/atom/cgi-bin"

And is working fine now.
I have never used this config on any fileserver i had, don't know why i need`it now, but it finally works.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests