XFileSharing Pro - Torrent Mod Torrent engine Disabled

Powerfull XFileSharing version

Moderator: admin

Message
Author
Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

Torrent Mod Torrent engine Disabled

#1 Postby Belgin Fish » Jul 27, 2011 1:54 am

hey, well I setup the torrent mod and everything, and then when I click on start engine under the torrent tab it says

STARTED:13410

but then I go back to the screen and it just says it's disabled again :(

if I try to upload a torrent file it just gets stuck at

Generating links...

any help? :(

Thanks

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Jul 27, 2011 8:48 pm

Try to run it from SSH console, or wait like 5 minutes, then try again.

Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

#3 Postby Belgin Fish » Jul 27, 2011 9:09 pm

when I tried running it from ssh this was put in the error log

Tue Jul 26 19:26:28 2011 # Logging to 'logs.txt'
Tue Jul 26 19:26:28 2011 # Setting my own niceness to 8
Tue Jul 26 19:26:28 2011 # ** WARNING ** Refusing to run with root privileges. Do not start ./bitflu.pl as root unless you are using
Tue Jul 26 19:26:28 2011 # ** WARNING ** the chroot option. In this case you must also specify the options runas_uid & runas_gid
Tue Jul 26 19:26:28 2011 # EXITING # Bitflu refuses to run as root


and I've tried it again 24 hours later still no luck :(

nyan
Posts: 163
Joined: Oct 28, 2010 8:01 pm

#4 Postby nyan » Jul 28, 2011 9:36 am

Belgin Fish wrote:when I tried running it from ssh this was put in the error log

Tue Jul 26 19:26:28 2011 # Logging to 'logs.txt'
Tue Jul 26 19:26:28 2011 # Setting my own niceness to 8
Tue Jul 26 19:26:28 2011 # ** WARNING ** Refusing to run with root privileges. Do not start ./bitflu.pl as root unless you are using
Tue Jul 26 19:26:28 2011 # ** WARNING ** the chroot option. In this case you must also specify the options runas_uid & runas_gid
Tue Jul 26 19:26:28 2011 # EXITING # Bitflu refuses to run as root


and I've tried it again 24 hours later still no luck :(

...
su www-data
./bitflu.pl

Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

#5 Postby Belgin Fish » Jul 28, 2011 11:11 am

nyan what does that do? I tried it and it's not working

Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

#6 Postby Belgin Fish » Jul 28, 2011 5:17 pm

tried running it as the non root user and it still isn't working

admin
Site Admin
Posts: 1800
Joined: Mar 22, 2006 12:32 pm

#7 Postby admin » Jul 29, 2011 7:33 am

What do you see in log when starting it from non-root account?

Belgin Fish
Posts: 101
Joined: Aug 09, 2010 6:30 pm

#8 Postby Belgin Fish » Jul 29, 2011 5:34 pm

nothing appears in the log


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests