XUpload - Transfer complete! but no file!

XUpload related questions

Moderator: admin

Message
Author
TAiS46
Posts: 3
Joined: Sep 05, 2006 12:28 am

Transfer complete! but no file!

#1 Postby TAiS46 » Sep 05, 2006 12:29 am

Hello,

i have read the other thread, but don't help!

Here my php info: http://imageup.de/info.php
Here the script: http://fileup.ya.cx/upload_form.html

Config file:

Code: Select all

package XUploadConfig;

BEGIN
{
  use Exporter;
  @XUploadConfig::ISA = qw( Exporter );
  @XUploadConfig::EXPORT = qw( $c );
}

our $c=
{
 # Directory for temporary using files
 temp_dir        => '/cgi-bin/temp',

 # Directory for uploaded files
 target_dir      => '/cgi-bin/uploads',

 # Path to the template using for upload status window
 templates_dir   => '/cgi-bin/Templates',

 # Allowed file extensions delimited with '|'
 ext_allowed     => 'jpg|jpeg|gif|png|rar|zip|mp3|avi|txt|csv',

 # The link to redirect after complete upload
 # This setting can be submitted from HTML form, then it will have priority
 redirect_link   => 'http://fileup.ya.cx/upload_form.html',

 # Max length of uploaded filenames(without ext). Longer filenames will be cuted.
 max_name_length => 64,

 # Type of behavior when uploaded file already exist on disc. Available 3 modes: Rewrite/Rename/Warn
 copy_mode       => 'Rename',

 # Maximum total upload size in Kbytes
 max_upload_size => 7000000000000,     

 # Time to keep temp upload files on server, sec (24 hours = 86400 seconds)
 temp_files_lifetime => 86400,

 # CSS names
 styles          => { 'black'   => 'black.css',
               'hitech'  => 'hi_tech.css',
               'aqua'    => 'aqua.css',
               'tiny'    => 'tiny.css',
                              'contrast'=> 'contrast.css',
             },

 # Template names
 templates => { 'simple' => 'simple.html',
                'hitech' => 'hitech.html',
           'nice'   => 'nice.html',
         },
};

1;



Thank for support

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Sep 05, 2006 5:35 am

You used wrong URL in this string:

Code: Select all

<form name="F1" enctype="multipart/form-data" action="/cgi-bin/xupload/upload.cgi?upload_id=" method="post" onSubmit="return StartUpload();" target="upload">


I guess it should be /cgi-bin/upload.cgi?upload_id=

TAiS46
Posts: 3
Joined: Sep 05, 2006 12:28 am

#3 Postby TAiS46 » Sep 05, 2006 8:31 am

Okay, i have fix the first problem!

But the new problem is, that i dont get an Download Link, is that correct? I see only, upload is finish, but on the main page, i dont see a link!

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » Sep 06, 2006 9:23 am

We don't have such feature like "Download Link Generation" right now. Probably it will be implemented in some upcoming versions.

To create download link after uploadiing you should move 'upload' folder to htdocs and create your own PHP or Perl script that will generate URL like http://www.YourSite.com/upload/UploadedFileName.zip


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests