XFileSharing Pro - [ERROR-2] -> Transfer Complete

Message
Author
spyer
Posts: 28
Joined: Mar 27, 2008 9:53 am

[ERROR-2] -> Transfer Complete

#1 Postby spyer » Apr 07, 2008 5:20 am

i've tried upload a file, large one... about 100Mb

it never shows the upload progress.. it say:

Please wait... then after a while it shows Transfer Complete


so.. there got to be something to be modified to make it work perfectly

tired it on my website, EZYfiles.net, up250.com.... the same problem with IE and FireFox

[EDIT] the file is still getting uploaded.. but the progress is not showing.

Thanks

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#2 Postby PilgrimX182 » Apr 07, 2008 10:16 am

That's strange cause other ppl using ezyfile.net are just fine with it.
Maybe some problems with your connection? Try from computer with different connection.

filesmart
Posts: 19
Joined: Apr 12, 2008 5:47 pm

#3 Postby filesmart » Apr 12, 2008 5:53 pm

I'm having this same issue with my users. They are complaining of files larger then 100mb of it doing this samething. Skipping the progress bar and going straight to saying file uploaded.

Now I'm not having this issue when I test it on Free Member or Premium account levels but everyone else seems to be.

I've had this issue reported to me by 4 members today alone. 2 are premium 500mb max and 2 are free members 200mb max. Issue involves both firefox and IE.

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#4 Postby PilgrimX182 » Apr 15, 2008 6:16 am

Just tested 140Mb file on up250.com - works just fine. Interesting.

Only can recommend this quick hack: in upload_status.cgi replace

Code: Select all

for(1..5)

with

Code: Select all

for(1..15)


This message shows when no flength file exist for 5 seconds now. This could happen when request with upload slows down somehow - maybe browser caching it or something.

Hack will increase "Transfer Complete" timeout to 15 seconds.

filesmart
Posts: 19
Joined: Apr 12, 2008 5:47 pm

#5 Postby filesmart » Apr 15, 2008 10:41 pm

I made suggested change. 7 different friends try files over 100mbs and all got the same issue. Said file transfer complete within 15 seconds. No upload progress bar no file in their accounts.

I've now tested it myself and i no longer can upload 100+mb files on my own server but have no issues doing it on up250.com

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#6 Postby PilgrimX182 » Apr 16, 2008 11:43 am

Give me your website URL, will check on it.

Below 100 Mb files are all fine?

As far as I remember we had near the same issue with server with mod_security or some such mod that was caching big uploads. Check apache mods, probably you can disable or increase this option.

filesmart
Posts: 19
Joined: Apr 12, 2008 5:47 pm

#7 Postby filesmart » Apr 17, 2008 3:27 pm

www.filesmart.net

I'm looking into the security mods now.

filesmart
Posts: 19
Joined: Apr 12, 2008 5:47 pm

#8 Postby filesmart » Apr 24, 2008 6:25 am

13. If you get message "Upload Complete" when trying to upload files over 128Mb, but with small files it's ok, change limit in your mod_security configuration file (usually modsec2.conf):
Code:

Code: Select all

SecRequestBodyLimit 1342177280


I had to add this whole line in as it was missing and restart only apache. Worked perfectly.


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 1 guest