XFileSharing Pro - Unable to run install.cgi

Message
Author
int_sharer
Posts: 3
Joined: Apr 05, 2011 1:15 pm

Unable to run install.cgi

#1 Postby int_sharer » Apr 05, 2011 1:25 pm

Hi,

i tried to install xfilesharing pro today on my server, but was unable to run the install.cgi.

First i though its a permission problem, but after some testing i got an error 500 from the script in the browser.

My Apache-error-log shows me a sysmalloc error

Code: Select all

[Tue Apr 05 16:03:54 2011] [notice] Apache/2.2.10 (Linux/SUSE) mod_ssl/2.2.10 OpenSSL/0.9.8h PHP/5.2.14 with Suhosin-Patch mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations

[Tue Apr 05 16:07:06 2011] [error] [client 127.0.0.1] perl: malloc.c:3096: sYSMALLOc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed.

[Tue Apr 05 16:07:06 2011] [error] [client 127.0.0.1] Premature end of script headers: install.cgi


What can i do now?

XFS 1.9
Suse Enterprise 11 SP1

Best regards.

admin
Site Admin
Posts: 1824
Joined: Mar 22, 2006 12:32 pm

#2 Postby admin » Apr 05, 2011 1:36 pm

That quite weird error. Never seen it before. Email ftp (or ssh if possible) access to support, we will check what exactly is wrong there.

MrTux
Posts: 3
Joined: Dec 10, 2013 8:31 am

Next error form malloc.c

#3 Postby MrTux » Dec 10, 2013 8:45 am

Hello!
I have the same problem in index.cgi near use Session. Here is log from Apache.

Code: Select all

perl: malloc.c:2369: sysmalloc: Assertion `(old_top == (((mbinptr) (((char *) &((av)->bins[((1) - 1) * 2])) - __builtin_offsetof (struct malloc_chunk, fd)))) && old_size == 0) || ((unsigned long) (old_size) >= (unsigned long)((((__builtin_offsetof (struct malloc_chunk, fd_nextsize))+((2 * (sizeof(size_t))) - 1)) & ~((2 * (sizeof(size_t))) - 1))) && ((old_top)->size & 0x1) && ((unsigned long)old_end & pagemask) == 0)' failed.

Other files (on example uu.cgi) works fine.

coolsalman_1
Posts: 15
Joined: Aug 04, 2012 10:22 pm

#4 Postby coolsalman_1 » Apr 08, 2014 1:57 pm

Hi sir,
i got the same issue. Permission of all my sites are right still i am facing this error.
please help me out. My script version 2.2

Internet Consumer
Posts: 148
Joined: May 28, 2013 1:51 am

#5 Postby Internet Consumer » Apr 11, 2014 12:55 pm

Just a guess but try to update your server

type in

yum update in the terminal make sure you log in as root.


Return to “XFileSharing Pro”