XUpload - Upload Form Doing Nothing

Posts: 2
Joined: Oct 24, 2006 12:25 pm

Upload Form Doing Nothing

#1 Postby GeorgeC » Oct 24, 2006 12:39 pm

Hi there,
I have just transfered my domain to a dedicated server and while Xuploadpro 2 worked perfectly on my old server I cannot get it to work on the new server.

The server is running Linux Fedora 5 and I have copied the file structure accross exactly as it was on the old server.

When I click to upload a file the page reloads but nothing happens.
I have CHMOD'ed all the .cgi files to be 755 and the upload and temp folders to be 777. I have also made the iframe visible on the upload page but there is no error message showing in it.

I have chacked the location of the pearl installation and (with my little knowledge of these things) can confirm it is in /usr/bin/ and is version 5.8.8.

I have included the recommended .htaccess file but to no effect.

I have noticed that although there is a cgi-bin folder in the domain folder there is also one in /var/www/ and by using a file_exists check in php can confirm that my upload file cannot find the upload.cgi file if I set the action to be "http://www.mydomain.com/cgi-bin/upload.cgi" but it can find it if I set it to "../cgi-bin/upload.cgi".

I hope that all this makes sence to someone and they have a suggestion before I go completely mad and give up web design for something a little less stressfull (like Iranian politician!!??).

Cheers in advance.

User avatar
Posts: 2186
Joined: Mar 22, 2006 1:39 pm

#2 Postby PilgrimX182 » Oct 24, 2006 12:51 pm

Hmmm...http://www.mydomain.com/cgi-bin/upload.cgi really doesn't work ..ah, sorry, jokin' :D But it would be usefull to have real URL(you can PM me it).

1) Have you updated paths in config?
2) Haven't you changed upload_form.html? enctype="multipart/form-data" is required in form tag for uploads.

You should use action="../cgi-bin/upload.cgi", that is correct.

Posts: 2
Joined: Oct 24, 2006 12:25 pm

#3 Postby GeorgeC » Oct 24, 2006 1:49 pm

Great Scot!! That was a speedy reply! (or was that time travel Doctor!!????)

I will PM you the real URL but to confirm:

1) Yes I have updated the paths (though I do wonder if the problem could be laying here!). The relevant part of the config file reads:

our $c=
# Directory for temporary using files
temp_dir => 'uploads',

# Directory for uploaded files
target_dir => 'temp',

# Path to the template using for upload status window
templates_dir => 'Templates',

# Log file. Set empty to disable logging
uploads_log => 'logs.txt',

# Allowed file extensions delimited with '|'
# Use '.*' to allow all extensions
ext_allowed => 'jpg|jpeg|gif|png|rar|zip|mp3|avi|txt|csv|bmp',

# Filename required mask (use standard perl regexp)
# Extension not using here (e.g. will use 'song_123' for 'song123.mp3')
# Leave empty if you don't need this custom filename validation
filaname_mask => '',

# Allow relative folder path for uploading files from HTML form ext_folder field
# Pathes with '..' are not allowed
# 0=no,1=yes. [Security Warning!]
allow_ext_folder => 0,

# URL to send all input values from upload page
url_post => 'http://www.mydomain.com/upload_callback.php',

# The link to redirect after complete upload
# redirect_link => '',

Upload callback is my custom callback page and is working correctly.
I have placed the upload and temp folders in the same place as the config file (/cgi-bin/xuploadpro/) and CHMOD 777 them.

2)Yes the upload form includes the "enctype="multipart/form-data". In full it reads "<form name="F1Upload" enctype="multipart/form-data" action="../cgi-bin/xuploadpro/upload.cgi?upload_id=" method="post" onSubmit="return StartUpload(this);">"

Cheers for the assistance and I will PM u in a mo!!