XUpload - [Xupload Pro] upload form in iframe doesn-t work with IE

Message
Author
kaboume
Posts: 10
Joined: Feb 06, 2009 12:59 pm

[Xupload Pro] upload form in iframe doesn-t work with IE

#1 Postby kaboume » Feb 16, 2009 12:37 pm

Hello,

If i put the upload form in an inframe, the status bar does'nt work. (with Firefox, no problem).

Have yu an idea ?

Thanks.

kaboume
Posts: 10
Joined: Feb 06, 2009 12:59 pm

#2 Postby kaboume » Feb 16, 2009 12:38 pm

Note : the file is correctly uploaded at this end.

kaboume
Posts: 10
Joined: Feb 06, 2009 12:59 pm

#3 Postby kaboume » Feb 16, 2009 12:56 pm

Here is my Html :


Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<title>Insert title here</title>
<script>
function go()   {
    parent.iframetoto.StartUpload(parent.iframetoto.document.F1Upload);
   parent.iframetoto.document.F1Upload.submit();
 
 }
</script>
</head>
<body>
<input type='button' name='bouton' value='go' onclick="javascript:go();"/>
<br/>
<iframe src='./upload_form_tiny.html' name='iframetoto' id='iframetoto'  frameborder="1" height='500px' width='500px'>
<br/><br/>
</body>
</html>

kaboume
Posts: 10
Joined: Feb 06, 2009 12:59 pm

#4 Postby kaboume » Feb 17, 2009 8:19 am

Is it because i use tio submit the form the two functions StartUpload() & submit() :

Code: Select all

parent.iframetoto.StartUpload(parent.iframetoto.document.F1Upload);
parent.iframetoto.document.F1Upload.submit();


Does i have to execute another function ?


Return to “XUpload”



Who is online

Users browsing this forum: No registered users and 0 guests