XFileSharing Pro - Upload not working (Nginx)

Message
Author
fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

Upload not working (Nginx)

#1 Postby fsadmin » Jan 24, 2011 3:00 pm

When i upload a file it dont generate the links. Also cronob is not running
if i try to do it manually than i get these errors


Code: Select all

Deleting symlinks for SRV=1...Done.
Deleting symlinks for SRV=12...Error when deleting syms. SRV=12.
File Not Found



Back to Main Site


Deleting symlinks for SRV=7...Error when deleting syms. SRV=7.
File Not Found



Back to Main Site


Deleting symlinks for SRV=8...Error when deleting syms. SRV=8.
File Not Found



Back to Main Site


-----------------------
ALL DONE

Back to server management


same with settings etc.

any suggestions? nginx is running on the fileserver

chrda
Posts: 296
Joined: Sep 14, 2009 7:16 pm

#2 Postby chrda » Jan 24, 2011 3:32 pm

apache is used for those kind of commands

nginx is just a backend for downloads

Atleast in the basic setup of XFS

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#3 Postby fsadmin » Jan 24, 2011 3:37 pm

but it seems like its a problem with the fileserverts and they are running with nginx..im 100% sure its a nginx problem..main server is working fine...and like you see on the code main server works fine just the 3 servers with nginx are not working

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#4 Postby ankurs » Jan 25, 2011 6:11 am

fsadmin wrote:but it seems like its a problem with the fileserverts and they are running with nginx..im 100% sure its a nginx problem..main server is working fine...and like you see on the code main server works fine just the 3 servers with nginx are not working


make sure apache is running and config are proper on those file servers

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#5 Postby fsadmin » Jan 25, 2011 3:30 pm

upload is working...now downloads are not working lol nginx is f.. up wiht no error message i want to have it removed was the biggest mistake ever to let them install it

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#6 Postby ankurs » Jan 25, 2011 3:34 pm

fsadmin wrote:upload is working...now downloads are not working lol nginx is f.. up wiht no error message i want to have it removed was the biggest mistake ever to let them install it


are you running apache and nginx on same ip and port ? then it wont work

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#7 Postby fsadmin » Jan 25, 2011 3:37 pm

it was working ankurs but these erros are coming alone with no touching anything i got 2 fileservers on 1 server 1 is working one not..do you know how to restart nginx on the 2 fileservers on the same server?

fsadmin
Posts: 41
Joined: Nov 09, 2010 1:22 pm

#8 Postby fsadmin » Jan 25, 2011 6:22 pm

the weird thing is when i set the first fileserver to offline or readonly and i upload files they will uploaded not to the next one they will be uploaded to the off server and if i upload 2 files together than the first 1 is not working but the second file is working but both will be saved on the same server


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 1 guest