uploading without progress bar

XUpload related questions

Moderator: admin

Message
Author
onasre
Posts: 2
Joined: Dec 23, 2006 12:09 am

uploading without progress bar

#1 Postby onasre » Dec 23, 2006 12:13 am

hello

i got the script to run but the progress bar doest work Ok , the pop up windows comes and the file info show but not progress

i have edited the .htaccess file .

the uploaded is going well becose i can see the file i uploaded in the uploads folder

try plz

http://www.jordanmusics.com/upload_form.html

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Dec 25, 2006 6:39 am

First of all it looks you have time anomaly cause your file system time not synchronized with perl time(this happens rarely). Do you run this xupload on cluster?
To fix this replace this srting in upload_status.cgi:

Code: Select all

my $ftime = (lstat($flength_file))[9]; # Upload start time


with

Code: Select all

my $ftime = time;


And progress not showing cause temp file not growing. This happens when mod_gzip or mod_security enabled(.htaccess should help, try to comment IfModule directives) or you run it on cluster and there is file synchronization kinda slow, so try to change in this string: "$curr_time-$modif_time>30" 30 to e.g. 90 and test again.

onasre
Posts: 2
Joined: Dec 23, 2006 12:09 am

#3 Postby onasre » Dec 25, 2006 11:57 pm

i tried that but the progress bar worked for once and never work again lol


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests