XFileSharing Pro - Verified BUG - 0 files but 18G of space used?

Powerfull XFileSharing version

Moderator: admin

Message
Author
qq_bbq
Posts: 122
Joined: Jul 05, 2009 11:33 pm

Verified BUG - 0 files but 18G of space used?

#1 Postby qq_bbq » Aug 01, 2010 12:26 am

I already run both file-to-db and db-to-file check successfully. But there are still 18G of space used on one of the file servers as shown from the admin panel. Why?

And I also confirmed by logging into the server that there is 18G of files.

Verified BUG:
I moved a file from server 1 to server 2. Server 2 successfully receives the file and the DB now points the file to server 2 for downloading. But the file is still in server 1. What is even more odd is the file in server 1 is not the same filesize as the file in server 2. Despite being the same filereal id.

Lots of space are probably wasted from moving files due to this bug. I think these bug happen from files that are moved but gets timeout while moving yet still got processed.

qq_bbq
Posts: 122
Joined: Jul 05, 2009 11:33 pm

#2 Postby qq_bbq » Aug 01, 2010 12:41 am

The fix should be the file-to-db check needs to check all servers pysically maybe by using list function (not through scanning in database) for duplicate filereal filename. If 2 or more file servers have the same filereal filename, check the database to see which file server it should be on and delete the files that are not listed in the database.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests