XFileSharing Pro - What config to use for bigger files?

Powerfull XFileSharing version

Moderator: admin

Message
Author
Timmy
Posts: 146
Joined: Feb 10, 2010 8:17 pm

What config to use for bigger files?

#1 Postby Timmy » Nov 18, 2011 9:48 am

Hello guys,

Can someone help me?
Is possible to upload 4.6GB files with this script?

I cant upload bigger files...
The max filesize that I uploaded was 3.6GB

I changed my php.ini first to:
post_max_size 10240M
upload_max_filesize 10240M

But got problems with all my websites that I have in the server... login problems for example...

Then I tried and worked for file 3.6GB but with 4.6GB the upload bar stops:
post_max_size 5120M
upload_max_filesize 5120M

What do you suggest?
Do I need to edit any config also?

helppppppp :)

glumbo
Posts: 211
Joined: Mar 11, 2011 6:26 am
Location: US

#2 Postby glumbo » Nov 18, 2011 9:59 am

The script doesn't use PHP settings. Change the timeout value in httpd.conf. The default is 60 seconds

Timmy
Posts: 146
Joined: Feb 10, 2010 8:17 pm

#3 Postby Timmy » Nov 18, 2011 10:04 am

I change the values here:
WHM Main >> Service Configuration >> PHP Configuration Editor

What is that? max_execution_time ?
Already have 60, but dont work for 4.6GB files

What value to use in memory_limit ?

glumbo
Posts: 211
Joined: Mar 11, 2011 6:26 am
Location: US

#4 Postby glumbo » Nov 18, 2011 10:30 am

It's in httpd.conf. I don't know where it is in WHM. You need to set it higher than 60

Timmy
Posts: 146
Joined: Feb 10, 2010 8:17 pm

#5 Postby Timmy » Nov 18, 2011 10:41 am

You are talking about max_execution_time right?
What value do you suggest?

I tried 300 but download was very very slowwww...

nyan
Posts: 163
Joined: Oct 28, 2010 8:01 pm

#6 Postby nyan » Nov 18, 2011 6:29 pm

Sure is hard to understand `THIS SCRIPT DOES NOT USE PHP`

edit the `connection timeout` setting to 600 or so for your filehosting domain in either httpd.conf apache2.conf or via whm.

Timmy
Posts: 146
Joined: Feb 10, 2010 8:17 pm

#7 Postby Timmy » Nov 19, 2011 1:34 am

Thank you for your reply nyan...

Is this?

WHM Main >> Service Configuration >> Apache Configuration >> Global Configuration
Image


By changing 300 to 600?

Btw, I have this values at:
WHM Main >> Service Configuration >> Apache Configuration >> Include Editor >> Pre Main Include >> All Versions:
ServerLimit 600
MaxClients 600
#MinSpareServers 10
#MaxSpareServers 30
StartServers 20
MaxRequestsPerChild 0
Timeout 50
KeepAlive On
KeepAliveTimeout 5
MaxKeepAliveRequests 150


Where do I change? The first one or second one?

hostlife
Posts: 170
Joined: Aug 13, 2011 12:34 pm

#8 Postby hostlife » Nov 19, 2011 2:35 am

ServerLimit 600
MaxClients 600

These are your apache connections limits. Increase your request timed out times

Timmy
Posts: 146
Joined: Feb 10, 2010 8:17 pm

#9 Postby Timmy » Nov 19, 2011 3:01 am

Thank you for your reply hostlife!
But where do I change? Here?
WHM Main >> Service Configuration >> Apache Configuration >> Include Editor >> Pre Main Include >> All Versions

And what values do you suggest?

The upload bar don't stop always in the same percentage... sometimes freezes at 57%, other times on 95%, 97%, ... weird.

glumbo
Posts: 211
Joined: Mar 11, 2011 6:26 am
Location: US

#10 Postby glumbo » Nov 19, 2011 6:18 am

Yes. Change timeout to 600 or higher

GMC
Posts: 172
Joined: Aug 15, 2009 4:48 am

#11 Postby GMC » Nov 28, 2011 1:54 pm

throwing in my 2 cents

turn off keep alive - should help


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests