XFileSharing Pro - Wrong IP error?

Message
Author
shynobee
Posts: 29
Joined: Apr 28, 2009 4:35 am

Wrong IP error?

#1 Postby shynobee » Jun 29, 2010 1:42 pm

Is there anyway to fix the "Wrong IP" msg that comes up when people.. particularly those in asian countries visit your filesharing site to download a file.

Because when this message comes up they aren't able to download the file.

nik0la
Posts: 102
Joined: Dec 30, 2009 1:50 pm

#2 Postby nik0la » Jun 29, 2010 1:47 pm

1 member on my site complain about that to..but since its only 1 member and its from asian countrys i dont care to much..but it will be a good if someone knows what is the problem and if have a fix for it..

admin
Site Admin
Posts: 1805
Joined: Mar 22, 2006 12:32 pm

#3 Postby admin » Jun 29, 2010 2:52 pm

Try to use forum search. This "problem" already raised here.

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

Re: Wrong IP error?

#4 Postby ankurs » Jun 29, 2010 3:13 pm

shynobee wrote:Is there anyway to fix the "Wrong IP" msg

Change Allow download from to All IPs

shynobee
Posts: 29
Joined: Apr 28, 2009 4:35 am

#5 Postby shynobee » Jun 30, 2010 12:34 am

Oh right got it now
Thanks.

and sorry admin. will do next time.

olesjas
Posts: 14
Joined: Dec 28, 2009 5:29 pm

#6 Postby olesjas » Jun 30, 2010 11:18 am

Users with UMTS/mobile connection get this error more often then users with DSL or cable, because their IP change with every pageview or if they get connected to another Access Point.

nik0la
Posts: 102
Joined: Dec 30, 2009 1:50 pm

#7 Postby nik0la » Jul 03, 2010 5:40 pm

i have changed to "ALLOW ALL IPS" but still on 3 servers i have problem with WRONG IP error. I have 1.7 ver..anyone knows how to fix this?

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#8 Postby ankurs » Jul 04, 2010 5:52 am

nik0la wrote:i have changed to "ALLOW ALL IPS" but still on 3 servers i have problem with WRONG IP error. I have 1.7 ver..anyone knows how to fix this?

r u using nginx mod on those servers ?

nik0la
Posts: 102
Joined: Dec 30, 2009 1:50 pm

#9 Postby nik0la » Jul 04, 2010 10:26 am

yes, i use nginx on all file servers

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#10 Postby ankurs » Jul 05, 2010 6:56 am

nik0la wrote:yes, i use nginx on all file servers

you need to change nginx config

nik0la
Posts: 102
Joined: Dec 30, 2009 1:50 pm

#11 Postby nik0la » Jul 05, 2010 2:36 pm

i forgot to update download.pm on that server :) fixed now tnx

qq_bbq
Posts: 122
Joined: Jul 05, 2009 11:33 pm

#12 Postby qq_bbq » Jul 05, 2010 5:23 pm

nik0la i have the same problem

i don't see download.pm where is it?

can you give step by step how to fix?

qq_bbq
Posts: 122
Joined: Jul 05, 2009 11:33 pm

#13 Postby qq_bbq » Jul 05, 2010 6:03 pm

nvm fixed

Arthur
Posts: 74
Joined: Dec 04, 2009 12:00 am

#14 Postby Arthur » Oct 05, 2010 4:13 pm

I have this same problem, just installed nginx and users say they are getting "wrong ip" message, out of country users I guess..Where is the nginx config or download.pm that you guys are talking about? and what do you change in it?

nik0la
Posts: 102
Joined: Dec 30, 2009 1:50 pm

#15 Postby nik0la » Oct 06, 2010 12:52 am

there is no fix if you have nginx mod..i have the same problem..


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests