64bit amd64 issue

Powerfull XFileSharing version

Moderator: admin

Message
Author
dzimi83
Posts: 66
Joined: Mar 09, 2009 1:08 pm

64bit amd64 issue

#1 Postby dzimi83 » Jul 19, 2009 10:21 pm

Hi,

I was tried to migrate from 32bit old P4 to the new one AMD Athlon(tm) 64 X2 Dual Core Processor and I have to stopped because script won't talk with Debian Lenny 64bit packages from amd64 port.

Logs here:
Filter_32_510.so

Code: Select all

[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi: Can't load 'Modules/auto/WSD/Filter/Filter.so' for module WSD::Filter: Modules/auto/WSD/Filter/Filter.so: wrong ELF class: ELFCLASS32 at /usr/lib/perl/5.10/XSLoader.pm line 64.
[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi:  at Modules/WSD/Filter.pm line 2
[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi: Compilation failed in require at Modules/Session.pm line 1.
[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi: BEGIN failed--compilation aborted at Modules/Session.pm line 1.
[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi: Compilation failed in require at /home/uploadspace.eu/public_html/cgi-bin/index.cgi line 6.
[Mon Jul 20 00:06:40 2009] [error] [client 89.79.205.21] [Mon Jul 20 00:06:40 2009] index.cgi: BEGIN failed--compilation aborted at /home/uploadspace.eu/public_html/cgi-bin/index.cgi line 6.


Filter_64.so

Code: Select all

[Mon Jul 20 00:16:44 2009] [error] [client 89.79.205.21] /usr/bin/perl: symbol lookup error: Modules/auto/WSD/Filter/Filter.so: undefined symbol: Perl_Tstack_sp_ptr
[Mon Jul 20 00:16:44 2009] [error] [client 89.79.205.21] Premature end of script headers: index.cgi


So.. please prepare the correct one Filter.so for the Debian Lenny AMD64 port tree. Thank you. Oh, and do it ASAP ;) I would like to switch to the new one quickly. (it is not dedicated, own colocation machines)

dzimi83
Posts: 66
Joined: Mar 09, 2009 1:08 pm

#2 Postby dzimi83 » Jul 22, 2009 11:58 am

PilgrimX182 ?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#3 Postby PilgrimX182 » Jul 22, 2009 5:18 pm


dzimi83
Posts: 66
Joined: Mar 09, 2009 1:08 pm

#4 Postby dzimi83 » Jul 22, 2009 7:32 pm

PilgrimX182 wrote:email to [email protected]


I did it but don't get reply, or my mail goes to the SPAM folder. Can you check it ?

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#5 Postby PilgrimX182 » Jul 23, 2009 5:54 am

Answered you.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 1 guest