a beginner got it working =)

XUpload related questions

Moderator: admin

Message
Author
Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

a beginner got it working =)

#1 Postby Waltman » Mar 11, 2010 11:03 am

Hello,

just bought the Pro version. Tried to follow the instructions and make it work locally with XAMPP.
- On the first step I copied the cgi files into the xampp/cgi-bin map
- Did the second one
- Third I think I have to set the _dirs to '#!"C:/xampp/cgi-bin/
- On the uploadform I tried this: action="../../../../cgi-bin/upload.cgi"
The form is located C:\xampp\htdocs\map_name\map_name\map_name\file.html
- removed the file

When I go to the page on the localhost I get the following:

----

'Server fout! error

Foutbericht: errormessage
couldn't create child process: 720003: upload_status.cgi

Indien u van oordeel bent dat deze server in fout is, gelieve de webmaster te contacteren. if you think this is a server error, contact etc..
Error 500
localhost
03/11/10 11:41:01
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

----

I am using latest version of FF on Vista.

I really need some help... and fast[/i]
Last edited by Waltman on Mar 24, 2010 7:37 pm, edited 2 times in total.

admin
Site Admin
Posts: 1785
Joined: Mar 22, 2006 12:32 pm

#2 Postby admin » Mar 11, 2010 1:55 pm

Check this first: http://www.sibsoft.net/forum/read-this-first-if-your-xupload-don-t-work-t84.html

There are some tricks to run it on windows.

Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

#3 Postby Waltman » Mar 11, 2010 5:00 pm

I already read the sticky, but I need more specific qlues... The stuff that I did so far, like the dirs. Should that part work?

peterdays
Posts: 55
Joined: Mar 10, 2010 3:56 pm

#4 Postby peterdays » Mar 11, 2010 5:15 pm

last time i got 500 error it was related to bad CHMOD settings (755)

Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

#5 Postby Waltman » Mar 11, 2010 5:58 pm

Ok, I checked all those CHMOD settings... using windows this is under the security tab right?

There are 6 options voor each group. In this case I thought the USERS should get the right permissions, since they are the only ones who are restricted...

So there is the (I might translate wrong)
- Full controll
- Edit
- Read and excecute
- Read
- Write
- Special thingy

775 means the USERS (5) can only Edit, Read and Excecute, Read
777 also means they can Write

Is this correct?

Might it be possible that I must test this on an online server, instead of a localhost?

EDIT 1:
on the FTP there are only the 3 options... trying this right now... makes more sense though

EDIT 2:
Online I get the error;
Forbidden
You do not have permission to access this document

One step closer... keeping you guys up to date so this might help more people

still confused though...
How do you open this file env.cgi from your browser if you can only acces the httpdocs to find the absolure URL for step 3...

I do find this all pretty poorly documentated and could use a setup example or a searchfunction for the forum....

Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

#6 Postby Waltman » Mar 23, 2010 8:39 pm

I still cant figure it out... Its driving me crazy...

the popup says its initializing upload
then i get the:
Forbidden
You do not have permission to access this document.

I tried following the sticky... but there are so many things to try... Feel like I tried all of them though...

back to step 3 op the install guide:
can u give me an example of an asoluture url for the XUploadConfig.pm

Last thing I tried: temp: http://www. URL .nl/cgi-bin/temp
target: http://www. URL .nl/cgi-bin/uploads
post: http://www. URL .nl/ FOLDER /post.php

I need some help, and fast

EDIT:
when I open the cgi.cgi file using my browser (only way I knew how to locate it was opening it with a ftp:// ... cgi.cgi method) This is the result:

#!"C:\xampp\perl\bin\perl.exe"

print "Content-Type: text/html\n\n";

print "OK";

Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

#7 Postby Waltman » Mar 24, 2010 4:42 pm

Still no luck... Is this just to advanced for me? I really need this to work. And running out of time for the deadline...

EDIT: ok... I guess you guys can call me stupid... CHMOD R X W isnt shown is the same order in de explorer window... R W X... so made a dumb mistake...

Waltman
Posts: 7
Joined: Mar 11, 2010 10:56 am

#8 Postby Waltman » Mar 24, 2010 7:31 pm

So I was at the point that I could select a file, noticed the form change and I could press upload... upload complete? Well, it says so...

Not, no progress etc...

After searching the forum I found this:

PilgrimX182 wrote:Make hidden iframe visible and you'll see after upload:

Code: Select all

CGI open of tmpfile: No such file or directory

this means you've set up temp dir wrong. Try to use just 'temp' or find out correct full path for it.


And it worked! Just posting this to help beginners, like me, out


Return to “XUpload”

Who is online

Users browsing this forum: No registered users and 0 guests