XFileSharing Pro - /cgi-bin/ files return 404 Not Found

Message
Author
th3hotcake
Posts: 51
Joined: Apr 07, 2009 7:24 pm

/cgi-bin/ files return 404 Not Found

#1 Postby th3hotcake » Jan 28, 2010 12:57 am

New server without control panels or anything.

Trying to install this additional server, but keep getting 404 Not Found when I try to connect to install_fs.cgi.

Code: Select all

<VirtualHost *:80>
   ServerAdmin [email protected]****
   
   DocumentRoot /var/www/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin/">
      Options +ExecCGI Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Any advice?

sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am

Re: /cgi-bin/ files return 404 Not Found

#2 Postby sherayusuf3 » Jan 28, 2010 2:25 am

th3hotcake wrote:New server without control panels or anything.

Trying to install this additional server, but keep getting 404 Not Found when I try to connect to install_fs.cgi.

Code: Select all

<VirtualHost *:80>
   ServerAdmin [email protected]****
   
   DocumentRoot /var/www/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin/">
      Options +ExecCGI Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Any advice?



you have mistake with your cgi-bin url
make sure /usr/lib/cgi-bin/ is your cgi-bin contain xfile sharing scripts
or change it

Code: Select all

   ScriptAlias /cgi-bin/ /var/www/cgi-bin/
   <Directory "/var/www/cgi-bin/">
      Options +ExecCGI Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

naga
Posts: 45
Joined: Dec 22, 2008 3:40 pm

#3 Postby naga » Jan 28, 2010 11:09 am

Also I think you need Allowoverride All
in order to get htaccess to work

th3hotcake
Posts: 51
Joined: Apr 07, 2009 7:24 pm

#4 Postby th3hotcake » Jan 28, 2010 8:07 pm

Thanks sherayusuf3, that solved the problem.

One of my expert friends gave me that solution last night and it worked great!


Return to “XFileSharing Pro”