XFileSharing Pro - Download counting problem

Powerfull XFileSharing version

Moderator: admin

Message
Author
joebloggs
Posts: 50
Joined: Mar 13, 2012 3:40 pm

Download counting problem

#1 Postby joebloggs » Jul 01, 2012 11:42 am

For some reason our script thinks a person has downloaded over 50gigs in 1 day even if they have downloaded only a few small files.


What can be causing this?

I think the script considers some of these small files to be gigantic? is this possible and what caused it and how to fix?

This is causing a lot of problems for us, has anyone else had this happen and how did you fix it?

The script stats were showing x100 actual site BW usage too, support fixed this but the bug i mention first still remains??

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#2 Postby ankurs » Jul 02, 2012 6:25 am

if a user click download button and generates link, then its counted towards its bandwidth even if he hasn't actually downloaded it

joebloggs
Posts: 50
Joined: Mar 13, 2012 3:40 pm

#3 Postby joebloggs » Jul 02, 2012 10:33 am

Thanks yes i understand that, however this problem is effecting a huge percentage of people.

There is certainly some bug in our script or db.

Lot of people are writing in to say they only downloaded 1 file and it says they have used their 50gigs up?

Anyone have any ideas on this?

thanks

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#4 Postby ankurs » Jul 02, 2012 10:46 am

joebloggs wrote:Lot of people are writing in to say they only downloaded 1 file and it says they have used their 50gigs up?

are those sharing same ips ? south east asian countries have this issue

joebloggs
Posts: 50
Joined: Mar 13, 2012 3:40 pm

#5 Postby joebloggs » Jul 02, 2012 10:58 am

Hello,

No, this is people from euro and Uk too.

It seems the script maybe thinks that some files are many TB in size when they are only small.

Im not sure what can be done.

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#6 Postby ankurs » Jul 02, 2012 11:10 am

make sure you have put proper values in settings, those values need to be in MB

joebloggs
Posts: 50
Joined: Mar 13, 2012 3:40 pm

#7 Postby joebloggs » Jul 02, 2012 11:37 am

hi,

thanks again for another suggestion, this i checked many times. The settings are correct.

There was some bug that caused the site BW to show 100x real usage.

Support fixed this issue.

However i think the same thing that caused that to happen caused another issue that has not been fixed. Something is happening to cause the script to believe the person is downloading gigs and gigs of data when in fact they are only downloading a few small files.

ankurs
Posts: 1054
Joined: Mar 10, 2009 2:34 am

#8 Postby ankurs » Jul 02, 2012 12:19 pm

whats ur site url ? would like to test it out

you can edit it out later on


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests