XFileSharing Pro - error when instalasi xfilesharing 1.6

Powerfull XFileSharing version

Moderator: admin

Message
Author
sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am
Location: Jakarta Indonesia
Contact:

error when instalasi xfilesharing 1.6

#1 Postby sherayusuf3 » Nov 04, 2009 6:55 am

http://mysite1/cgi-bin/fs.cgi

Software error:

111 at /var/www/cgi-bin/fs.cgi line 10.

For help, please send mail to the webmaster ([email protected]), giving this error message and the time and date of the error.

on http://mysite2/cgi-bin/fs.cgi
i got same error, between server1 and server1 i set database table replication
this my.cnf config

#replicate-do-db = b3b45g1l4
replicate-do-table = b3b45g1l4.Comments
replicate-do-table = b3b45g1l4.Files
replicate-do-table = b3b45g1l4.Folders
replicate-do-table = b3b45g1l4.IP2Files
replicate-do-table = b3b45g1l4.IP2RS
replicate-do-table = b3b45g1l4.News
replicate-do-table = b3b45g1l4.Payments
replicate-do-table = b3b45g1l4.Reports
#replicate-do-table = b3b45g1l4.Servers
replicate-do-table = b3b45g1l4.Sessions
replicate-do-table = b3b45g1l4.Stats
replicate-do-table = b3b45g1l4.Torrents
replicate-do-table = b3b45g1l4.Transactions
replicate-do-table = b3b45g1l4.Users

replicate-ignore-table = b3b45g1l4.Servers
#replicate-ignore-table = b3b45g1l4.Sessions

#replicate-wild-do-table=dbname.tablename%
#replicate-wild-ignore-table=dbname.tablename%


please help me asap

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#2 Postby PilgrimX182 » Nov 04, 2009 7:10 am

You shouldn't open fs.cgi directly in browser, it's for special api calls only.

sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am
Location: Jakarta Indonesia
Contact:

#3 Postby sherayusuf3 » Nov 04, 2009 9:08 am

PilgrimX182 wrote:You shouldn't open fs.cgi directly in browser, it's for special api calls only.


but i got error when add file server


Name
cgi-bin URL
files URL
Max disk usage Gb
Server only for Regular users
Premium users
Status
File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR
Not Found

The requested URL /cgi-bin/fs.cgi was not found on this server.

Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.2 with Suhosin-Patch Server at bebasupload.com Port 80
upload.cgi: OK

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#4 Postby PilgrimX182 » Nov 04, 2009 9:31 am

It's "404 Not Found" error, no 111. Make sure fs.cgi is on fileserver. Cause upload.cgi check passed fine.

sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am
Location: Jakarta Indonesia
Contact:

#5 Postby sherayusuf3 » Nov 04, 2009 9:54 am

PilgrimX182 wrote:It's "404 Not Found" error, no 111. Make sure fs.cgi is on fileserver. Cause upload.cgi check passed fine.


youre /FS-dist/cgi-bin/ script folder not contain fs.cgi
only on /cgi-bin folder contain fs.cgi

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#6 Postby PilgrimX182 » Nov 04, 2009 8:39 pm

My bad, sorry. Indeed, fs.cgi is on MAIN only.
Hmm...then this error means api.cgi get 404 error. Then check your site_cgi in XFileConfig.pm

sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am
Location: Jakarta Indonesia
Contact:

#7 Postby sherayusuf3 » Nov 05, 2009 9:02 am

PilgrimX182 wrote:My bad, sorry. Indeed, fs.cgi is on MAIN only.
Hmm...then this error means api.cgi get 404 error. Then check your site_cgi in XFileConfig.pm


thnk for reference,
i change:
site_cgi => 'http://www1.domain.com/cgi-bin on server 1 and
site_cgi => 'http://www2.domain.com/cgi-bin on server 2

previously
site_cgi => 'http://domain.com/cgi-bin on server 1 and
site_cgi => 'http://domain.com/cgi-bin on server 2

done, thnks PilgrimX182 youre the best :)


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests