XFileSharing Pro - MP4 Moov Atom

Powerfull XFileSharing version

Moderator: admin

Message
Author
speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

MP4 Moov Atom

#1 Postby speakerbox » Apr 23, 2011 11:39 pm

Where can I specify where mp4 box places the moov atom as at this time it takes a while for the initial MP4 videos to start playing. The video begins downloading quickly right away and downloads roughly 8 percent before it begins to stream in our player; We'd prefer that it starts after 1 or 2 percent.

Thanks!!

komi
Posts: 161
Joined: Nov 27, 2009 12:41 pm

#2 Postby komi » Apr 24, 2011 1:09 am

I do not believe this functionality has been implemented yet. However, if you want to do it yourself you should use:

Code: Select all

MP4Box -inter 500 filename.mp4

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#3 Postby speakerbox » Apr 24, 2011 8:46 pm

I made some changes to the enc.pl file how-ever it doesn't seem to change where the moov atom is placed.

Code: Select all

    my @rr = `/usr/bin/MP4Box -add $c->{upload_dir}/$dx/$code.mp4 -isma -inter 500 $c->{upload_dir}/$dx/$code.mp4x`;
    #my @rr = `/usr/local/bin/MP4Box -add $c->{upload_dir}/$dx/$code.mp4 -isma -inter 500 $c->{upload_dir}/$dx/$code.mp4x`;


I also tried 100 but it didn't have an affect.

komi
Posts: 161
Joined: Nov 27, 2009 12:41 pm

#4 Postby komi » Apr 24, 2011 9:36 pm

You are already using the -isma parameter which makes the -inter parameter obsolete. Both parameters do its job just fine and because of that I think your problem has nothing to do with file's moov atom at all.

Do you have an example link?

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#5 Postby speakerbox » Apr 24, 2011 10:53 pm

The -isma parameter doesn't affect the -inter parameter.

I can show you an example - whats your contact information?

komi
Posts: 161
Joined: Nov 27, 2009 12:41 pm

#6 Postby komi » Apr 25, 2011 1:10 am

As far as I know -isma already moves the moov atom to the beginning, without the -inter parameter.

Sorry cannot share contact information.

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#7 Postby speakerbox » Apr 25, 2011 6:55 am

Does anyone else have any suggestions for this? I guess my other option is pseudo streaming.

komi
Posts: 161
Joined: Nov 27, 2009 12:41 pm

#8 Postby komi » Apr 25, 2011 12:05 pm

Without an example link, it is hard to determine where the problem is.

Also you might want to use H264 Streaming Module (http://h264.code-shop.com/trac).
Last edited by komi on Apr 28, 2011 7:07 pm, edited 1 time in total.

nyan
Posts: 163
Joined: Oct 28, 2010 8:01 pm

#9 Postby nyan » Apr 25, 2011 7:29 pm

use ffmpeg's qt-faststart after making the mp4

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm
Location: UFO Lab
Contact:

#10 Postby PilgrimX182 » Apr 26, 2011 11:03 am

Also try to change streamer value in player code to http instead of file by default. It's in index_dl.pm I think.

PowerChaos
Posts: 521
Joined: Dec 19, 2009 5:12 pm
Location: belguim
Contact:

#11 Postby PowerChaos » Apr 27, 2011 5:10 am

and to be able to play at start with out all those modifications is it even better to install psuedostreaming ( H264 pseudostreaming)

it is a mess to get the player working for it , but as soon it is fixed then it will work

lets explain what that is
pseudostreaming loads the end of the file first to know the size of the video and then use keys to say his position

on that way you can skip parts of a movie and play it with out a problem
as it does not need to load the video to play

here is a previeuw
http://www.boosterking.com/embed-feurjqpnf2i8.html

and if you like to know the size , it is 2.3GB
this is what you get as normal user
5040231.mp4.mp4 - 44.4 MB

Greets From PowerChaos

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#12 Postby speakerbox » Apr 28, 2011 5:11 pm

I changed the values for the player to a 3 second buffer - the flash files start more quickly but the mp4 files are the same.

The main issue is that large files take over a minute to start playing. The moov atom is a certain percent into the video file so it works ok for smaller files.

I tried the psudostreaming with nignx and I couldn't seem to compile nginx to make it work.

I'll keep looking around for a solution.

venture89
Posts: 95
Joined: Aug 30, 2011 12:11 am
Location: Planet Z

#13 Postby venture89 » Jun 27, 2012 7:16 am

nyan wrote:use ffmpeg's qt-faststart after making the mp4


Any idea how to do this? Do not have much experience with editing enc.pl file.
Thanks in advance


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests