XFileSharing Pro - New Setup Issue..

Powerfull XFileSharing version

Moderator: admin

Message
Author
SolidSnke
Posts: 6
Joined: Aug 11, 2010 6:17 pm
Contact:

New Setup Issue..

#1 Postby SolidSnke » Aug 11, 2010 6:25 pm

This is probably very simple and I believe it is all based around the .htaccess. But my brain has reached its limit so I would like to tap into the wonderful more knowledgeable people here on the site for help.

My issue is after I did the install.cgi and removed it, it tried to goto the login page and all I get is a 404 error. This is after I changed the .htaccess file to reflect the dir it resides under, which is /xfs.

My .htaccess looks like follows for the www/xfs dir;

Code: Select all

deny from 127.1.1.4
deny from 127.1.1.1

AddDefaultCharset utf-8
RewriteEngine on
RewriteCond %{HTTP:Authorization} ^(.*)
RewriteRule ^(.*) - [E=HTTP_CGI_AUTHORIZATION:%1]

RewriteCond   %{REQUEST_FILENAME} !-f
#RewriteRule    ^([0-9A-Za-z]{12})(\/?.+|$)$      /cgi-bin/xfs/index.cgi?op=download1&id=$1&fname=$2 [L]
RewriteRule    ^([0-9A-Za-z]{12})(\/.+|\.html?|$)   /cgi-bin/xfs/index_dl.cgi?op=download1&id=$1&fname=$2 [L]

RewriteRule    ^embed-([0-9A-Za-z]{12})\.html$      /cgi-bin/xfs/index_dl.cgi?op=video_embed&file_code=$1 [L]
RewriteRule    ^embedmp3-([0-9A-Za-z]{12})\.html$   /cgi-bin/xfs/index_dl.cgi?op=mp3_embed&file_code=$1 [L]
RewriteRule    ^box$               /cgi-bin/xfs/index_box.cgi [L]

RewriteRule    ^$               /cgi-bin/xfs/index.cgi [L]
RewriteRule    ^free([0-9]+)\.html$         /cgi-bin/xfs/index.cgi?op=registration&aff_id=$1 [L]
RewriteRule    ^checkfiles\.html$         /cgi-bin/xfs/index.cgi?op=checkfiles [L]
RewriteRule    ^contact\.html$            /cgi-bin/xfs/index.cgi?op=contact [L]
RewriteRule    ^premium\.html$            /cgi-bin/xfs/index.cgi?op=payments [L]
RewriteRule    ^login\.html$            /cgi-bin/xfs/index.cgi?op=login [L]
RewriteRule    ^catalogue(.*)\.html$         /cgi-bin/xfs/index.cgi?op=catalogue&date=$1 [L]
RewriteRule    ^news([0-9]*)\.html$         /cgi-bin/xfs/index.cgi?op=news&page=$1 [L]
RewriteRule    ^n([0-9]+)-.*\.html$         /cgi-bin/xfs/index.cgi?op=news_details&news_id=$1 [L]
RewriteRule    ^faq\.html$            /cgi-bin/xfs/index.cgi?op=page&tmpl=faq [L]
RewriteRule    ^tos\.html$            /cgi-bin/xfs/index.cgi?op=page&tmpl=tos [L]
RewriteRule    ^links\.html$            /cgi-bin/xfs/index.cgi?op=links [L]

RewriteCond   %{REQUEST_FILENAME} !-f
RewriteRule    ^pages/([a-z0-9\-\_]+).html      /cgi-bin/xfs/index.cgi?op=page&tmpl=$1$2 [L]

RewriteCond   %{REQUEST_FILENAME} !-f
RewriteCond   %{REQUEST_FILENAME} !-d
RewriteRule    ^users/([0-9A-Za-z\-_]{4,64})/?([0-9]+|$)   /cgi-bin/xfs/index.cgi?op=user_public&usr_login=$1&fld_id=$2 [L,NC]

RewriteRule    \.pm$               /404.html [L]

ErrorDocument 404 /404.html


Hopefully I missed something easy.

ofcourse my dir structure is /www is my root, /www/cgi-bin is the cgi-bin, /www/xfs is where I uploaded the htdocs files.

Do I need to adjust the /www .htaccess file as well or just the /www/xfs one? (btw, there is nothing in the /www dir save a standard index.html that is a placeholder for now.)

Thanks for the help.

PS -- I have searched this and found some answers, but they all seem to point to the .htaccess file and seem to be not solving my issue.

admin
Site Admin
Posts: 1800
Joined: Mar 22, 2006 12:32 pm

#2 Postby admin » Aug 11, 2010 7:41 pm

What is your domain name?

SolidSnke
Posts: 6
Joined: Aug 11, 2010 6:17 pm
Contact:

#3 Postby SolidSnke » Aug 12, 2010 12:57 am

securedigitalfiles.com

ok so I have made a bit of progress with the install. I forgot to enable the .htaccess support for my site (what a terrible host I am ;) ) but after I did that things worked a bit better but there are still a few issues I am trying to sort out which I will post back here when I figure them out a bit more of what the problem is.

Thanks again. And thank you for such a great product.


Return to “XFileSharing Pro”

Who is online

Users browsing this forum: No registered users and 0 guests