XFileSharing Pro - Server Configuration / Set-up

Message
Author
speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

Server Configuration / Set-up

#1 Postby speakerbox » Sep 26, 2010 6:22 am

Hello,

Recently I started a filesharing/videosharing website and recently I’ve been having some issues with my website.

The main website and the file server are located on the same server. The server is a xenon quad core with 8GB of ram and a 1gb port. I’ve been noticing that files will take a long time to start loading. For instance, you will click play on the video however it will take up to 1 minute for the video to actually start playing. What’s weird is that some videos will start no problem while other take forever to start. Is this a hard disk problem? My drives are currently not raided and there’s only 200 files on our servers.

I’m also wondering what’s the best server configuration. I’m totally new at this so it’s hard for me to really know what I need. Over the last seven days I’ve been averaging 551mbps and pretty peaking at 989mbps. I’m going to get another server to offload my current one however I’m wondering what’s my best option. I could get another server however that won’t offload the traffic that’s already going to my other server. Can I do some sort of load balancing? Maybe a CDN or something?

What do you guys recommend? I need to decided soon so I can provide users with a quality service; my sites useless if files cannot be streamed at a good speed.

chrda
Posts: 296
Joined: Sep 14, 2009 7:16 pm

#2 Postby chrda » Sep 26, 2010 12:59 pm

You need to move your website to a other server. Dont have fileserver and web on the same box.

and you need nginx on your fileservers.

Seems like you need a new fileserver also if you are peaking the Gbit line.

And you might consider hiring someone to setup your Main web, with for example Litespeed webserver.

Do these things and your on the right track

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#3 Postby speakerbox » Sep 26, 2010 6:19 pm

Hi,

I’ve had nginx installed on my file server already. Right now my server has two hard drives. Both the file server and the website are on the same hard drive. What I might do for now is switch the file server over to the second hard drive so that only files are located on it rather then everything being run from the same hard drive.

I have a management team that can install litespeed on my server. I want to first figure out if I should order two more servers or just one. I just want everything to run smoothly so that my visitors come back.

chrda
Posts: 296
Joined: Sep 14, 2009 7:16 pm

#4 Postby chrda » Sep 27, 2010 8:19 am

Litespeed will not work with your fileserver, only with XFS web.

Nginx need to be installed by sibsoft for it to work seamless with XFS

If your bandwidth are maxed you might consider new server, or speedlimit each Thread.

speakerbox
Posts: 73
Joined: Aug 20, 2010 4:39 am

#5 Postby speakerbox » Sep 27, 2010 4:17 pm

I've already had them install the nginx mod on my server.

This is another thing I'm seeing. A video will begin streaming and the download speed will be pretty good how-ever the video will buffer even thought it's already downloaded more of the video. See the image below.

Image


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 1 guest