XFileSharing Pro - Server Management: fs.cgi ERROR when adding the first server

Message
Author
rickdang
Posts: 5
Joined: Feb 27, 2009 7:36 am

Server Management: fs.cgi ERROR when adding the first server

#1 Postby rickdang » Feb 27, 2009 7:53 am

Hi to all,
I installed XfileSharing Pro following the INSTALL.txt directives. At point #5 I tried to add a new server, using these data:

cgi-bin URL: http://abc.server.com/cgi-bin
files URL: http://abc.server.com/xfs/files

But this was the output:

File Server tests:
api.cgi: OK
temp dir exist: OK
temp dir mkdir: OK
temp dir rmdir: OK
tmp dir exist: OK
tmp dir mkdir: OK
tmp dir rmdir: OK
upload dir exist: OK
upload dir mkdir: OK
upload dir rmdir: OK
htdocs dir exist: OK
htdocs dir mkdir: OK
htdocs dir symlink: OK
htdocs dir symlink del: OK
htdocs dir rmdir: OK
config read: OK
config write: OK
fs.cgi: ERROR <----------------
upload.cgi: OK
htdocs URL accessibility: OK

There's another point I did not understand, and maybe could be related to the above error.

I installed XFileSharing Pro onto a subfolder, let's say http://abc.server.com/xfs, and subsequently configured both XFileConfig.pm and .htaccess. After a lot of tries all worked fine... but I never saw the "There are no servers available for upload" message.

When setting up the Server Management options, first I tried to configure with these (suggested) values:

cgi-bin URL: http://abc.server.com/cgi-bin/xfs
files URL: http://abc.server.com/xfs/files

But the error I got was worser:

=============== ERROR ==============
api.cgi: ERROR (
Not Found

The requested URL /cgi-bin/xfs/api.cgi was not found on this server.
Apache/2.2.3 (CentOS) Server at abc.server.com Port 80
)
upload.cgi: ERROR (problems with link)
=============== END ================

My server's operating system is CentOS 5.

I'm not an Apache expert, so thanks in advance for any kind suggestion.

Rick

sherayusuf3
Posts: 94
Joined: Jan 18, 2009 4:29 am

Re: Server Management: fs.cgi ERROR when adding the first se

#2 Postby sherayusuf3 » Feb 28, 2009 12:16 am



cgi-bin URL: http://abc.server.com/cgi-bin/xfs <-- should be cgi-bin URL: http://abc.server.com/cgi-bin

make sure you chmod 755 *.cgi
if got same error, try to reupload fs.cgi

rickdang
Posts: 5
Joined: Feb 27, 2009 7:36 am

#3 Postby rickdang » Mar 01, 2009 11:33 pm

Hi sherayusuf3, thank you for your reply.

I did all the things you suggested me, but the fs.cgi is still in ERROR state.

I also tried to set chmod 0777, but nothing got better.

What other kind of things should I do to solve?

Thanks,
Rick

User avatar
PilgrimX182
Posts: 2182
Joined: Mar 22, 2006 1:39 pm

#4 Postby PilgrimX182 » Mar 01, 2009 11:36 pm

Usualy I face this problem when
1) Main Server cgi-bin folder specified wrong in XFileConfig.pm
2) File Server unable to connect to Main. (domain not resolving, server security settings)
3) fs.cgi is invalid (not 755, have windows linebreaks)

rickdang
Posts: 5
Joined: Feb 27, 2009 7:36 am

#5 Postby rickdang » Mar 02, 2009 1:02 am

Hi PilgrimX182,
that's it: fixing XFileConfig.pm solved the issue.

Thank you again,
Rick


Return to “XFileSharing Pro”



Who is online

Users browsing this forum: No registered users and 0 guests